[solved] Hatch solid fill color

Please use this forum to post feedback and suggestions related to QCAD version 3

Moderator: andrew

[solved] Hatch solid fill color

Postby liderbug » Wed Oct 24, 2012 4:06 pm

I'd wag someone else has ... but my searching can't find.

Confusion: I select an item, click Hatch-Solid = black. But my color is red. How do I change from black to red - hello Google? Turns out just go ahead had fill. It's the Hatch solid vs pattern box that lies (leads one astray). Seems the Hatch-Solid 'display' is always black but draws 'color'.

Then foreground/background works, yahoo...

Now a question - is there a way to (because my printer is B/W) have a border color (black) and a different fill color (white)? That way hidden lines would hide.

Thanks - Great program.

Chuck
liderbug
Newbie Member
 
Posts: 9
Joined: Fri Apr 02, 2010 11:24 pm

Re: Hatch solid fill color

Postby Clive » Wed Oct 24, 2012 5:26 pm

liderbug wrote: Seems the Hatch-Solid 'display' is always black but draws 'color'.


Yes and if your 'model' space background is black then the preview in the Hatch - Solid Fill will show as White! and it will fill with the set color dependent on the layer you are working on.

liderbug wrote: Now a question - is there a way to (because my printer is B/W) have a border color (black) and a different fill color (white)? That way hidden lines would hide.


To achieve this you can go to Edit - Application Preferences - Graphics View and 'un tick' the Color Adjustment option - Prevent White on White/Black on Black display.

Graphics View.png
Graphics View.png (137.38 KiB) Viewed 4925 times


Then when you set up for example different layers:
Border - with color Black
Fill White - color White.
and work on the different layers for drawing the border and on the layer 'Fill White' you should get the desired result in your print out.

Graphics View 2.png
Graphics View 2.png (15.9 KiB) Viewed 4925 times


Hope this helps :wink:
User avatar
Clive
Moderator / Drawing Help
 
Posts: 1185
Joined: Thu Aug 25, 2011 9:28 pm
Location: UK

Re: Hatch solid fill color

Postby gwood » Sun Jul 24, 2016 5:15 pm

Hmmm, this post was from 2012 and never got an answer. Is this forum active?

To answer the OP's question (what I THINK he's asking, anyway), I always use a separate layer for my fills. I set the color at the layer level. Then, all my fills/hatches will be that color. This works very well in that if you decide to change the color later, simply edit the layer, change the color in one spot, and every fill contained by that layer automatically changes color.

Now a question of my own, related to the OP's question:

I would like to effectively crop an inserted graphic, by using rectangles which are filled with WHITE. This should be easy-- draw the rectangles in the places I want white to appear, then be sure the graphic is "behind" the rectangles. Trouble is, the white rectangles show up black, instead of white. Is there a way around this?

I'm using the pro version, 3.1.2.0.

Thanks.
gwood
Newbie Member
 
Posts: 8
Joined: Fri Feb 20, 2009 10:32 pm

Re: Hatch solid fill color

Postby Husky » Sun Jul 24, 2016 5:44 pm

gwood wrote:Trouble is, the white rectangles show up black, instead of white. Is there a way around this?

I'm using the pro version, 3.1.2.0.

Hi gwood,

I don't know your Background color but maybe this effect is based to the "Color Adjustment" settings.

Husky-2016.07.24-01.png
Husky-2016.07.24-01.png (64.62 KiB) Viewed 325 times


Please check your "Prevent white on white / black on black display" settings.
Work smart, not hard: QCad Pro
User avatar
Husky
Moderator/Drawing Help/Testing
 
Posts: 1170
Joined: Wed May 11, 2011 9:25 am
Location: USA

Solved: (Re: Hatch solid fill color)

Postby gwood » Sun Jul 24, 2016 7:00 pm

Husky,

Using your tip, I was able to solve my problem. Thank you. You may consider this question SOLVED.

As an aside, changing this color adjustment setting reveals a strange interaction between the graphical display, and the print-preview display. To wit: I use a black background in my graphical display, and with this setting unchecked, I am unable to see black lines (which normally display as white). It's not a big deal, I just have to re-check the color adjustment box after I do my print.

Ideally it seems it would be nice to have greater separation between the graphical display, and the print-preview display. Maybe that's already been done in a newer version? I haven't upgraded in a good while.

Thanks again for your quick reply.
gwood
Newbie Member
 
Posts: 8
Joined: Fri Feb 20, 2009 10:32 pm

Re: Solved: (Re: Hatch solid fill color)

Postby Husky » Sun Jul 24, 2016 10:12 pm

gwood wrote:To wit: I use a black background in my graphical display, and with this setting unchecked, I am unable to see black lines (which normally display as white). It's not a big deal, I just have to re-check the color adjustment box after I do my print.

Launch the "Print Preview", switch to the "Black/White Mode" in the Options bar and all your lines are visible ...

Husky-2016.07.24-02.png
Husky-2016.07.24-02.png (24.64 KiB) Viewed 317 times


... no need to toggle always this setting in "Application Preferences" :wink:
Work smart, not hard: QCad Pro
User avatar
Husky
Moderator/Drawing Help/Testing
 
Posts: 1170
Joined: Wed May 11, 2011 9:25 am
Location: USA

Re: Hatch solid fill color

Postby gwood » Mon Jul 25, 2016 2:51 am

The Black/White button makes all my lines visible, but it also gives me a monochrome print (no color). The other setting did exactly what I needed though. Thanks again.
gwood
Newbie Member
 
Posts: 8
Joined: Fri Feb 20, 2009 10:32 pm


Return to QCAD 3 Suggestions and Feedback

Who is online

Users browsing this forum: Bing [Bot] and 1 guest