segmentation fault for qcad 3.0 prof [solved]

If you are having problems with QCAD version 3, post here. Please report bugs here.

Moderator: andrew

segmentation fault for qcad 3.0 prof [solved]

Postby gandalf » Sat Feb 23, 2013 3:20 pm

I have a box running kubuntu 12.1, qcad 3.0 Prof opens fine on that box. I installed 3.0 prof on my laptop, kubuntu 12.1, installed the ia32... libraries to get rid of the libGLU.so.1 error and now I get a segmentation fault message. Any ideas? Thanks.
gandalf
Junior Member
 
Posts: 13
Joined: Mon Aug 18, 2008 1:06 pm

Re: segmentation fault for qcad 3.0 prof

Postby andrew » Mon Feb 25, 2013 8:25 am

Did you install both, the "ia32-libs" and "ia32-libs-gtk" package? On some installations the latter seems to be required as well.
User avatar
andrew
Site Admin
 
Posts: 2379
Joined: Fri Mar 30, 2007 6:07 am

Re: segmentation fault for qcad 3.0 prof

Postby gandalf » Mon Feb 25, 2013 1:08 pm

In ubuntu there is a transitional package ia32-libs-multiarch that has the libraries as dependencies. I do see gtk engine files as dependencies. I will check into my other system.
gandalf
Junior Member
 
Posts: 13
Joined: Mon Aug 18, 2008 1:06 pm

Re: segmentation fault for qcad 3.0 prof

Postby gandalf » Mon Feb 25, 2013 6:55 pm

I checked my desktop system and it has the same packages installed. So, I guess it is a deeper issue. Quite unfortunate. I will post the logs in case it helps with possible code changes.
gandalf
Junior Member
 
Posts: 13
Joined: Mon Aug 18, 2008 1:06 pm

Re: segmentation fault for qcad 3.0 prof

Postby gandalf » Sat Mar 23, 2013 7:29 pm

unfortunately I ran an upgrade on my desktop unit and now I get the same error as on my laptop: ./qcad: line 38: 27089 Segmentation fault (core dumped) LD_LIBRARY_PATH="$DIR" "$binary" $OPT1 $OPT2 "$@"
gandalf
Junior Member
 
Posts: 13
Joined: Mon Aug 18, 2008 1:06 pm

Re: segmentation fault for qcad 3.0 prof

Postby andrew » Sat Mar 23, 2013 7:56 pm

Thanks for the information. It seems like the update has caused the problem. Possibly an update to an incompatible version of glibc or another library.

Can you please let me know what package of QCAD you have installed, the regular Linux package or the one with -alt in the package name?

You might also want to try the current development snapshot ( 3.0.8 ) available from your download area. It ships with its own version of glibc which might fix the problem.

To download QCAD 3.0.8, please follow our instructions at:
http://www.ribbonsoft.com/en/customer-area

Then scroll down to "Development Snapshots".
User avatar
andrew
Site Admin
 
Posts: 2379
Joined: Fri Mar 30, 2007 6:07 am

Re: segmentation fault for qcad 3.0 prof

Postby gandalf » Sun Mar 24, 2013 2:05 pm

Unfortunately when trying to download I get an expiration date message. I had purchased sometime back in mid 2011 and was upgraded to the 3.0. Will I have to purchase again and risk it not working?
gandalf
Junior Member
 
Posts: 13
Joined: Mon Aug 18, 2008 1:06 pm

Re: segmentation fault for qcad 3.0 prof

Postby andrew » Sun Mar 24, 2013 9:07 pm

I've sent you a temporary, direct link for QCAD 3.0.8. Please let me know if that solves the issue or not. Thanks.
User avatar
andrew
Site Admin
 
Posts: 2379
Joined: Fri Mar 30, 2007 6:07 am

Re: segmentation fault for qcad 3.0 prof

Postby Pierre de Québec » Tue Apr 30, 2013 12:00 am

Hello Andrew,

Will there be a patch to fix the problem or do I have to buy the next version of QCAD? I no longer have access to the download area.

QCAD v 3.0
Platform X86-64 bits
Linux 3.8.0-19-generic
Kubuntu Raring

Thank you.
Pierre de Québec
Registered Member
 
Posts: 2
Joined: Tue Aug 30, 2011 11:08 am

Re: segmentation fault for qcad 3.0 prof

Postby andrew » Tue Apr 30, 2013 1:13 pm

Pierre: I've sent you an e-mail with direct download links for QCAD 3.0.9.
User avatar
andrew
Site Admin
 
Posts: 2379
Joined: Fri Mar 30, 2007 6:07 am

Re: segmentation fault for qcad 3.0 prof

Postby Pierre de Québec » Tue Apr 30, 2013 11:25 pm

Thank you very much Andrew. The Hyperlink works well as version 3.0.9. Is the 3.0.9 version is an official or is it a transitional version?

I will buy the next official release.

Sincerely,

Pierre
Pierre de Québec
Registered Member
 
Posts: 2
Joined: Tue Aug 30, 2011 11:08 am

Re: segmentation fault for qcad 3.0 prof

Postby andrew » Wed May 01, 2013 7:53 am

3.0.9 is a development snapshot (not intended for production use). The reason it works on your Linux system is that it includes the libraries "libgcc_s.so.1" and "libstdc++.so.6". If you copy those over to your QCAD 3.0.0 (stable) installation, you should be able to run 3.0.0 as well.
User avatar
andrew
Site Admin
 
Posts: 2379
Joined: Fri Mar 30, 2007 6:07 am

Re: segmentation fault for qcad 3.0 prof

Postby pipo » Tue May 28, 2013 6:25 am

Hi Andrew, I have exactly the same situation as Pierre, (same error message, 2011 license), except that I'm running Opensuse 12.3.

I see that I have installed 2 c++ libs, maybe the reason for the problem ?

libstdc++6-32bit-4.7.2_20130108-2.1.6.x86_64
libstdc++33-32bit-3.3.3-38.1.1.x86_64

Before I purchase the next release could you help out with the 3.09 link ?

TIA, peer
pipo
Newbie Member
 
Posts: 6
Joined: Fri Nov 02, 2007 10:23 am
Location: Germany

Re: segmentation fault for qcad 3.0 prof

Postby andrew » Thu Aug 08, 2013 1:31 pm

This problem should no longer exist in newer QCAD releases which link against older versions of libstdc++ and glibc.
User avatar
andrew
Site Admin
 
Posts: 2379
Joined: Fri Mar 30, 2007 6:07 am

Re: segmentation fault for qcad 3.0 prof [solved]

Postby cmcgrath5035 » Wed Aug 14, 2013 7:19 pm

I am in a similar state to pipo, a recent update to my openSUSE 12.3 system yields the error message referenced above.
I have QCAD 3.0.0 installed, purchased in 2011 (was 2.x at the time, then updated).

Is there no way to patch my system to keep 3.0.0 running?
cmcgrath5035
Active Member
 
Posts: 44
Joined: Thu Oct 13, 2011 7:38 pm

Next

Return to QCAD 3 Troubleshooting and Problems

Who is online

Users browsing this forum: No registered users and 3 guests