Library

If you are having problems with QCAD version 3, post here. Please report bugs here.

Moderator: andrew

Library

Postby TheEnglishPatient » Tue Feb 28, 2012 7:24 pm

In the File system tab of the Library Browser no elements are shown, only the folders - so how does one select a block to insert?

If one browses alternatively through the pages on the Tags tabs, it shows the icons but goes on allocating memory (GB's!) for ever till the Library Browser eventually hangs (after a few pages).

So what now? Or is my machine sick?

Win 7-64
TheEnglishPatient
Junior Member
 
Posts: 12
Joined: Sun Feb 19, 2012 12:56 pm

Postby andrew » Mon Mar 05, 2012 4:36 pm

This could have indeed been a memory allocation problem. We've fixed it for the next release (coming days).
User avatar
andrew
Site Admin
 
Posts: 2618
Joined: Fri Mar 30, 2007 6:07 am

Postby andrew » Wed Mar 07, 2012 6:30 pm

QCAD 3 RC4 should fix the problem (available as of today).
User avatar
andrew
Site Admin
 
Posts: 2618
Joined: Fri Mar 30, 2007 6:07 am

Library Browser does still not work for me

Postby TheEnglishPatient » Tue Mar 13, 2012 9:43 am

Hmmm... I just installed RC4 now and there is no improvement really: If I open the library browser, it opens on the 'tag' tab and shows me the icons of the first page and says at the bottom 'page 1 / 31 (6095 items found)', which looks ok(ish). I can then with the arrow flip to the next page, which takes about 30 sec (!) to display but again looks ok. If I then flip to page 3 it begins to pull on the CPU like crazy and then the library browser hangs altogether. I monitored what happens in the windows task manager, and it does no longer seem to allocate memory like mad, but it now grabs the entire CPU forever.
In the folders tab, I still don't see any icons to select at all.

So I am still stuck.
TheEnglishPatient
Junior Member
 
Posts: 12
Joined: Sun Feb 19, 2012 12:56 pm

Postby andrew » Tue Mar 13, 2012 8:53 pm

Did you add some of your own directories to the library?

I am guessing so, since the library that comes with QCAD 3 has only about 800 items.

It would be helpful to know what kind of drawings are included in the paths you have added to the library browser.

Note that if your own library directories contain very large and complex drawing files, generating the icons for them might indeed take a very long time during which the library browser is busy (using all CPU power there is).

The first thing to try is to use the library as it comes, without any custom directories configured.

Then add only drawings / directories to the library which you really intend to insert through the library browser. For example configuring the library browser to include "C:\" is not a good idea as it will have to search your entire hard drive C for drawing files and index them. This might take hours or days depending on the size of your hard drive and the number of drawings that are found.

You might also want to reduce the number of items that are shown per page in the search results (-> Preferences). The default is "100". Generating 100 icons can take 10sec, 30sec or 30min, again depending on the complexity of the drawings.
User avatar
andrew
Site Admin
 
Posts: 2618
Joined: Fri Mar 30, 2007 6:07 am

Progress, but...

Postby TheEnglishPatient » Thu Mar 15, 2012 12:43 pm

Thanks Andrew, there seem to be a couple of things conspiring here:

a) You are right, I have thrown everything out of the library and added then folders successively back in, and indeed there were a few dodgy third party dxf's which seem to load forever and cause a hang problem. Displaying more than 100 icons per page does not seem to be a smart idea either.

b) I had also some seemingly valid files which did not load at all (maybe and older dxf format?) that the library does not support?

So, I am sort of happy on the tags page, however, I still do not see anything in the lower pane of the 'File system' tab - should there not be the icons for the selected folder? I really would like to organise my library with a folder structure - otherwise that tab is pretty useless as you then seemingly can only select through the tags and I see no way of mass-tagging the files.

Secondly, on the tags tab it appears that if you click repeatedly on the page arrows (bottom left) before the icons on the page have completely displayed the program goes on to generate icons back to the last fully displayed page. So if you quickly go to page 40 without ever waiting in between for instance, you may get 4000 icons (which of course takes forever). Feels like another look at the eventhandler is warranted.
TheEnglishPatient
Junior Member
 
Posts: 12
Joined: Sun Feb 19, 2012 12:56 pm


Return to QCAD 3 Troubleshooting and Problems

Who is online

Users browsing this forum: No registered users and 2 guests