QCAD 3.0.0 Professional and Fedora 18

Post your question about installing or upgrading QCAD version 3

Moderator: andrew

QCAD 3.0.0 Professional and Fedora 18

Postby pilotkip » Wed Mar 27, 2013 2:16 pm

I just installed QCAD 3.0.0 on a fresh installation of Fedora 18. It works great! However the installation took an additional step that I thought I would share here.

I began by following the lead from the Fedora 17 topic on this forum, making sure to have the appropriate 32-bit libraries loaded, specifically:
Code: Select all
yum install mesa-libGLU.i686
yum install libXrender.i686
yum install glib2.i686
yum install libSM.i686
yum install qtwebkit.i686
yum install glibc-devel.i686


This was insufficient and I continued to receive Segmentation Fault errors. It wasn't until I stumbled upon an article by James McDonald that I found an additional step:
Code: Select all
cd ~/opt/qcad-3.0.0-prof-linux
./assistant


Apparently 'assistant', which is the help system for QCAD, recognizes and fixes a problem that the qcad binary is unable to recognize and fix.

This QCAD forum blocks links to external sites to prevent spam, so if you want to find the original article, the url is jamesmcdonald.id.au/it-tips/qcad-3-0-0-on-fedora-18
pilotkip
Registered Member
 
Posts: 1
Joined: Wed Mar 27, 2013 1:55 pm

Return to QCAD 3 Installation and Upgrades

Who is online

Users browsing this forum: No registered users and 1 guest

cron