error while loading shared libraries

Post your question about installing or upgrading QCAD version 3

Moderator: andrew

error while loading shared libraries

Postby Jasleen Kaur » Tue Jun 18, 2013 10:02 am

Today I compiled QCAD from Github.
No installation steps are there. :(
I follow http://www.qcad.org/en/component/conten ... om-sources

During compilation, lot of Warnings come :wink:
I got this error for shared libraries:
./qcad-bin: error while loading shared libraries: libqcadecmaapi.so:
cannot open shared object file: No such file or directory



then,
Above problem solved by manually coping the shared libraries (shown in error)
(like: libqcadecmaapi.so, libqcadentity.so, libqcadcore.so, libqcadgrid.so,
libqcadgui.so, libqcadoperations.so, libqcadsnap.so,
libqcadspatialindex.so, libqcadstemmer.so, libspatialindexnavel.so )
from your QCAD source code to /usr/lib/ :D

Is there any other alternative rather doing it manually?
Jasleen Kaur
Registered Member
 
Posts: 2
Joined: Tue Jun 18, 2013 9:08 am

Re: error while loading shared libraries

Postby andrew » Tue Jun 18, 2013 10:29 am

You can alternatively set LD_LIBRARY_PATH:

LD_LIBRARY_PATH=. ./qcad-bin


There is no installation procedure if QCAD is compiled from sources. Please note that compiled, installable packages are available for Windows, Linux and Mac OS X at:
http://www.qcad.org/en/qcad-downloads-trial
User avatar
andrew
Site Admin
 
Posts: 2522
Joined: Fri Mar 30, 2007 6:07 am

Re: error while loading shared libraries

Postby Jasleen Kaur » Tue Jun 18, 2013 11:07 am

Ok
But compilation steps/ link to it, should be mentioned in github.

cheer!
Jasleen Kaur
Jasleen Kaur
Registered Member
 
Posts: 2
Joined: Tue Jun 18, 2013 9:08 am

Re: error while loading shared libraries

Postby andrew » Tue Jun 18, 2013 11:42 am

OK, done :)
User avatar
andrew
Site Admin
 
Posts: 2522
Joined: Fri Mar 30, 2007 6:07 am


Return to QCAD 3 Installation and Upgrades

Who is online

Users browsing this forum: No registered users and 2 guests