Layer and entities attributes

If you are having problems with QCAD 2.1/2.2, post here. Please report bugs here.

Moderator: andrew

Layer and entities attributes

Postby faber » Wed Mar 16, 2011 8:24 pm

I have found another "strange" behaviour of Qcad.
This the situation: I have several text in layer "Descrizioni"- color green-; I want to move some words/number in another layer; I select the text to be moved, then edit, then attributes, then I select the desired layer "Numerazione"-color red-, but I leave "unchanged" color, width and line type.
the expected behaviour is to see the text always green.
But it becomes red.

What am I missing??
faber
Junior Member
 
Posts: 21
Joined: Mon Mar 14, 2011 5:15 pm

Postby andrew » Wed Mar 16, 2011 8:40 pm

That is correct behavior. The texts have most likely set their color attribute to "ByLayer", so moving them to another layer will affect their color.

Please read up on layers in your e-book chapter "Layers":

"[...] Because of this close relationship between layers and attributes, the attributes are handled by the layer and not by the individual entities. For example if the color of layer Walls is set to blue, all elements on that layer (i.e. all walls) are shown in blue."
User avatar
andrew
Site Admin
 
Posts: 2554
Joined: Fri Mar 30, 2007 6:07 am

Postby faber » Sat Mar 19, 2011 2:14 pm

thank you, I will do...
faber
Junior Member
 
Posts: 21
Joined: Mon Mar 14, 2011 5:15 pm


Return to QCAD 2.1/2.2 Troubleshooting and Problems

Who is online

Users browsing this forum: No registered users and 1 guest