QCAD 3.0 RC2 crashes on open - Linux

If you are having problems with QCAD version 3, post here. Please report bugs here.

Moderator: andrew

Postby hungerburg » Tue Jan 31, 2012 1:36 pm

This is just a quick idea, but this message seems to indicate something with theming: (qcad-bin:10530): GdkPixbuf-WARNING **: Bug! loader 'png' didn't set an error on failure.

The qcad script should take care of that on x64 systems. But nevertheless, try and launch "qtconfig" from shell or applications menu and choose another theme, eg. "plastique".
User avatar
hungerburg
Senior Member
 
Posts: 125
Joined: Fri May 28, 2010 7:35 pm

Postby andrew » Tue Jan 31, 2012 10:12 pm

hungerburg wrote:The qcad script should take care of that on x64 systems. But nevertheless, try and launch "qtconfig" from shell or applications menu and choose another theme, eg. "plastique".


Or try the -style command line switch:

./qcad -style platsique
User avatar
andrew
Site Admin
 
Posts: 2619
Joined: Fri Mar 30, 2007 6:07 am

Postby HerbSmith » Thu Feb 02, 2012 3:23 am

Andrew,
I assume you meant plastique. I tried that, here's what I got:

./qcad -style plastique
.
./qcad-bin
./qcad: line 38: unexpected EOF while looking for matching `"'
./qcad: line 40: syntax error: unexpected end of file
HerbSmith
Junior Member
 
Posts: 10
Joined: Mon Jan 30, 2012 2:58 pm

Postby andrew » Thu Feb 02, 2012 9:03 am

That's just the wrapper script that breaks on your system. What version of bash do you have installed?

Code: Select all
bash --version


To work around the script, start QCAD as follows:

Code: Select all
LD_LIBRARY_PATH=. ./qcad-bin -style plastique


If you are using another shell, the idea here is to make sure that QCAD looks in the current working directory for shared libraries (like the file 'libQtWebKit.so.4' you have mentioned). You may also export LD_LIBRARY_PATH or the equivalent thereof in your shell.
User avatar
andrew
Site Admin
 
Posts: 2619
Joined: Fri Mar 30, 2007 6:07 am

Postby HerbSmith » Thu Feb 02, 2012 2:02 pm

Andrew,

GNU bash, version 4.2.10(1)-release (i686-pc-linux-gnu)
Copyright (C) 2011 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>

This is whatever came with the Linux Mint 12 installation.

The suggestion worked just fine and yes, I can fix that up so it has it each time I log in.

Thank you so much. QCAD is great, I have been a user for some time and am very excited about the new version.

Herb
HerbSmith
Junior Member
 
Posts: 10
Joined: Mon Jan 30, 2012 2:58 pm

Postby hungerburg » Fri Feb 03, 2012 6:46 pm

If I understand correctly, the qcad wrapper only forces "plastique" on systems with a kernel that advertises *Ubuntu*, but the theming issue also affects systems, that will not match this. Eg. mint, ubuntu with homegrown kernels etc.

The /black list/ could be amended, or turned into a /white list/ instead or plastique forced on all 64bit systems?
User avatar
hungerburg
Senior Member
 
Posts: 125
Joined: Fri May 28, 2010 7:35 pm

Postby andrew » Fri Feb 03, 2012 6:56 pm

-style plastique should probably be forced on all 64bit systems using the Gnome Desktop (or certain versions thereof). Forcing it on all 64bit systems will leave the significant number of KDE desktop users with a non-consistent user interface experience. The start-up script also seems to require adjustments to make it Bash version 4 compatible.
User avatar
andrew
Site Admin
 
Posts: 2619
Joined: Fri Mar 30, 2007 6:07 am

Postby hungerburg » Sun Feb 05, 2012 11:07 pm

This is with a Ubuntu 10.04. bash version is 4.1.5. The startupscript works flawlessly. Eg qcad -style motif tests OK. I also use it to run autostart scripts.

Curiously, here now pure qcad-bin (RC2) does not crash with the default theme, as it did half a year ago. This is not a gnome desktop, but an XFCE one, but the default theme, as seen from qtconfig, surely looks gtk-ish. I do not know, what has changed in the meantime. A quick google search turns out this post:
"http://www.qtcentre.org/threads/35092-QT-4-7-GdkPixbuf-WARNING-**-Bug!-loader-png-didn-t-set-an-error-on-failure"
Maybe the remedy therein helps:
Code: Select all
sudo update-mime /usr/share/mime/
sudo update-mime-database /usr/share/mime/

HerbSmith, what do you say?
User avatar
hungerburg
Senior Member
 
Posts: 125
Joined: Fri May 28, 2010 7:35 pm

Re: QCAD 3.0 RC2 crashes on open - Linux

Postby perello » Mon May 21, 2012 4:19 pm

Have the same behaviour within Ubuntu 12.04 and latest nvidia driver version 295.53. I also tried older nvidia drivers with no luck.
perello
Newbie Member
 
Posts: 6
Joined: Mon May 21, 2012 4:16 pm

Re: QCAD 3.0 RC2 crashes on open - Linux

Postby andrew » Mon May 21, 2012 5:22 pm

perello wrote:Have the same behaviour within Ubuntu 12.04 and latest nvidia driver version 295.53. I also tried older nvidia drivers with no luck.


Did you try this workaround?

Code: Select all
LD_LIBRARY_PATH=. ./qcad-bin -style plastique


Does this affect QCAD 3 RC2 or the latest QCAD 3 RC5?
User avatar
andrew
Site Admin
 
Posts: 2619
Joined: Fri Mar 30, 2007 6:07 am

Re: QCAD 3.0 RC2 crashes on open - Linux

Postby perello » Tue May 22, 2012 10:26 am

Same result. Thats on qcad-trial rc5.
perello
Newbie Member
 
Posts: 6
Joined: Mon May 21, 2012 4:16 pm

Re: QCAD 3.0 RC2 crashes on open - Linux

Postby andrew » Tue May 22, 2012 1:57 pm

perello wrote:Same result. Thats on qcad-trial rc5.


Please elaborate. What is the exact output you get after starting QCAD?

If you are on a 64bit Linux, did you install package 'ia32-libs' which is required to run 32bit applications?
User avatar
andrew
Site Admin
 
Posts: 2619
Joined: Fri Mar 30, 2007 6:07 am

Re: QCAD 3.0 RC2 crashes on open - Linux

Postby perello » Wed May 30, 2012 8:58 am

It's on 32 bit linux. Qcad opens the initial window to choose units of measure, just mouse clicking on it makes the program crash.

No error messages, I can do a strace if that helps out.

As a side note I have exactly the same behaviour using varicad, so I suspect it must be something with the graphics (opengl?).

cheers
perello
Newbie Member
 
Posts: 6
Joined: Mon May 21, 2012 4:16 pm

Re: QCAD 3.0 RC2 crashes on open - Linux

Postby andrew » Wed May 30, 2012 9:10 am

Is there any command line output at all?

You may also want to try running it with the script debugger enabled (recommended for debugging ONLY):

./qcad -enable-script-debugger

An strace might be helpful to get an idea of where things go wrong, thanks.
User avatar
andrew
Site Admin
 
Posts: 2619
Joined: Fri Mar 30, 2007 6:07 am

Re: QCAD 3.0 RC2 crashes on open - Linux

Postby perello » Wed May 30, 2012 9:30 am

the output of

qcad -enable-script-debbuger > ~/qcad_errors.txt 2>&1

whole X windows crashes when the first window is opened

then

cat qcad_errors.txt

#38-Ubuntu SMP Tue May 1 16:21:07 UTC 2012 i686
Debug: Init script plugins...
Debug: RDocument::setCurrentBlock: removing block: 22
Debug: TIMER: 45936 ms - "loading and initializing plugins"
qcad-trial-bin: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.


I added the strace output, as an attachment,

cheers
qcad-strace.txt
(12.91 KiB) Downloaded 183 times
perello
Newbie Member
 
Posts: 6
Joined: Mon May 21, 2012 4:16 pm

PreviousNext

Return to QCAD 3 Troubleshooting and Problems

Who is online

Users browsing this forum: Bing [Bot] and 2 guests