Cannot hatch : pattern files not visible in the list (GUI)

If you are having problems with QCAD version 3, post here. Please report bugs here.

Moderator: andrew

Cannot hatch : pattern files not visible in the list (GUI)

Postby aaa » Fri Dec 13, 2013 4:13 pm

Hi,

when I want to hatch a selection, I get the popup but the pattern list is empty.
The fill function works well, however.

The pat files are in the directories /usr/local/share/qcad/patterns/imperial and metric, and are readable.
I can import them using the library browser but I have to hatch manually…

Do you have any idea to solve this problem ?
Thanks.

(Qcad 3.4.2.0 on FreeBSD 9.2)
aaa
Junior Member
 
Posts: 13
Joined: Tue Dec 10, 2013 9:58 pm

Re: Cannot hatch : pattern files not visible in the list (GU

Postby andrew » Fri Dec 13, 2013 8:56 pm

Please report this bug to the person who did the FreeBSD port. Hatch patterns should reside in subdirectory 'patterns' of the QCAD installation directory.
User avatar
andrew
Site Admin
 
Posts: 2544
Joined: Fri Mar 30, 2007 6:07 am

Re: Cannot hatch : pattern files not visible in the list (GU

Postby aaa » Fri Dec 13, 2013 10:31 pm

Thanks for your really fast reply !

What is the installation directory ?
It's not the home directory (e.g. ~/.qcad), isn't it ?

In my installation, everything seems to be in /usr/local/share/qcad/ : fonts, libraries, patterns, plugins, scripts, ts.
Fonts and libraries apparently work ; I don't know for the plugins, scripts, ts. But the patterns files are not found by the GUI.

Finally, what should I report exactly ?
Can I test something (move files to the right location) ?
aaa
Junior Member
 
Posts: 13
Joined: Tue Dec 10, 2013 9:58 pm

Re: Cannot hatch : pattern files not visible in the list (GU

Postby andrew » Sat Dec 14, 2013 10:11 am

I'd recommend looking into the official tar.gz for Linux and replicating its directory and file structure:
http://qcad.org/en/qcad-downloads-trial

QCAD is best installed to and run from one single directory containing the binary and all resources. That directory (call it 'application bundle' if you want) can be installed anywhere.
User avatar
andrew
Site Admin
 
Posts: 2544
Joined: Fri Mar 30, 2007 6:07 am

Re: Cannot hatch : pattern files not visible in the list (GU

Postby aaa » Sat Dec 14, 2013 2:12 pm

After a while, I found this workaround :

I copied the binary with the resources as you told :
sudo cp /usr/local/bin/qcad-bin /usr/local/share/qcad/

It works ! That's a first step !
Last edited by aaa on Sat Dec 14, 2013 2:41 pm, edited 1 time in total.
aaa
Junior Member
 
Posts: 13
Joined: Tue Dec 10, 2013 9:58 pm

Re: Cannot hatch : pattern files not visible in the list (GU

Postby aaa » Sat Dec 14, 2013 2:36 pm

Is there a way to declare the "installation" directory ?

— a command line option : qcad --my-own-installation-directory /usr/local/share/qcad/
— a global variable in the sources : MyOwnInstallationDirectory = "/usr/local/share/qcad/"
— something else
aaa
Junior Member
 
Posts: 13
Joined: Tue Dec 10, 2013 9:58 pm


Return to QCAD 3 Troubleshooting and Problems

Who is online

Users browsing this forum: No registered users and 1 guest