QCAD Bugtracker

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category QCAD (main)
  • Assigned To
    Andrew
  • Operating System Linux (All / Other)
  • Severity Medium
  • Priority Very Low
  • Reported Version 3.23.0
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: QCAD Bugtracker
Opened by kurt - 04.09.2019
Last edited by Andrew - 09.09.2019

FS#1938 - Segfault when trying to insert block from library (Fedora 30)

(base) [[email protected] qcad-3.23.0-pro-linux-x86_64]$ ./qcad
QCAD version 3.23.0
10:21:34: Debug: calling odInitialize
10:21:34: Debug: dropped global XDATA (no res buf): “ViewportCenter” 10:21:52: Debug: importing file: /home/kforrester/Resilio Sync/Technical/Process Engineering/equipment_tag_and_name.dxf
./qcad: line 9: 3844 Segmentation fault (core dumped) LD_LIBRARY_PATH=”$DIR” “$binary” “[email protected]

QCAD has unexpectedly quit.

Please use the offscreen platform plugin for headless systems
(without a running X11 server):
./qcad -platform offscreen

In addition, you might have to override the default Qt style
to prevent the loading of a native desktop style (such as GTK):
./qcad -style plastique

I have tested this in version 3.22.1 too and get the same result. Reverting all the way back to 3.13.1 results in an operable version of qcad when working on the same file and library blocks.

Closed by  Andrew
09.09.2019 06:41
Reason for closing:  Works for me
Additional comments about closing:  

No further information / files provided by user.

Admin
Andrew commented on 04.09.2019 09:43

Not reproducible here with any file.

Please attach or e-mail the target file you are inserting to and the library item file (/home/kforrester/Resilio Sync/Technical/Process Engineering/equipment_tag_and_name.dxf).

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing