QCAD Bugtracker

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category QCAD/CAM
  • Assigned To
    Andrew
    Carlton
  • Operating System Windows 10
  • Severity Low
  • Priority Very Low
  • Reported Version 3.23.0
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: QCAD Bugtracker
Opened by Carlton - 24.11.2019
Last edited by Andrew - 25.11.2019

FS#2003 - QCADCAM Crashes when starting up

I am trying to run the QCADCAM v3.23.0 64 bit version under Windows 10 x64. When I start the program, I get the splash screen showing it loading all of the plugins. When it gets to around 67% (Gerber stuff), the program crashes. I get the following exception:

Unhandled exception at 0x00007FFC5F51C706 (MxMGLV64.dll) in qcad.exe: 0xC0000005: Access violation reading location 0×0000000003304318. occurred

I also loaded the 64 bit version of just plain QCAD and it works with no problems.
I also tried loading the 32 bit version of QCADCAM and while it does not crash, it does not display any of the menus, toolbars, or toolboxes. it displays only a black screen with the title bar.

Closed by  Andrew
25.11.2019 09:37
Reason for closing:  Not a bug
Admin
Andrew commented on 25.11.2019 09:37

This behaviour more likely indicates an OpenGL problem (OpenGL driver invalid, incompatible or not available).

Please remove the file "plugins/qcadgles3d.dll" and try again. Note that without that plugin, you will not have a 3D preview / simulation widget. To fix the problem, a working OpenGL driver would need to be installed. This can be daunting on Windows and is only really worth the trouble if you need the 3D simulation widget.

Carlton commented on 25.11.2019 15:01

Thank you, that did the trick!

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing