QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask TypeSeveritySummaryStatusProgress
2081QCAD (main)Bug ReportLowDimension label color at existing files will change to ...Assigned
0%
Task Description

The new QCAD feature “dimension label color” will change the label color at existing drawings to “Custom”.
In my opinion it should be by default “by Layer” until the user decide to change the color by him/herself. ;-)

2079QCAD/CAMBug ReportLowFull screen mode (F11) - Menu / drop down menus not wor...Assigned
0%
Task Description

https://www.qcad.org/rsforum/viewtopic.php?f=33&t=7269

2078QCAD (main)Bug ReportLowDraw > Hatch: Small gap tolerated by QCAD, not by DXF/D...Assigned
0%
Task Description

https://qcad.org/rsforum/viewtopic.php?f=33&t=7254

It seems to be an accuracy problem.
The original hatch boundaries are defined from 732 single entities.
These interconnect with an accuracy better then 1e-10 except for a gap of 0.000814 in two places.

Creating a Hatch of these entities with TA-HA is rather slow but succesfull.
After Save-Close-Open the Hatch may look different or may even be missing (=Null).

Suspected is that:
The recreation off the Hatch on load uses some other accuracy setting.
The outer boundary is not found and only some inner ones are considered as outer.

But that explains not why it looks fine after initial creation.
Nor that the outcome of a retry may vary.

Regards,
CVH

Showing tasks 1 - 3 of 3 Page 1 of 1

Available keyboard shortcuts

Tasklist

Task Details

Task Editing