Open

Toolbar / Icon:
   
Menu: File > Open
Shortcut: Ctrl+O (Mac: ⌘O)
Commands: open

Description

Use this command to open a drawing file. The file is loaded and shown in a new window within the QCAD application window. You can switch between different loaded drawings using the menu "Windows" or the tabs at the top of the drawing area.

QCAD Professional

Editing CXF Fonts

QCAD comes with a collection of line fonts in its own CXF format. Line fonts are sometimes used in CAD instead of TrueType fonts. Line fonts are also often used for engraving or other further processing.
QCAD can load and edit fonts in CXF format. To load an existing font, simply use the menu File > Open and choose the format filter "CXF Font Files (*.cxf)". Then choose the font file you want to open. The fonts that come with QCAD are stored in directory "fonts" of your QCAD installation.
The font glyphs (representation of the various letters and symbols) are loaded into blocks. Make sure the block list is visible (View > Block List), so you can navigate through the font glyphs.
Each block has a name in the format "[Hexadecimal Unicode] [Symbol]", for example "0x0041 A" for a capital "A" with Unicode 65 (41 in hexadecimal).
By convention, a capital "A" should be constructed with a height of 9 drawing units. When the font is used for a text, it is scaled by QCAD according to the text height chosen.
Glyphs should have their reference point 0,0 at the lower left corner of the base line. In the CXF format, glyphs can contain lines, arcs and polylines. Splines may be used, but are converted into polylines during export.