Search found 28 matches

by garciadelcastillo
Fri Jul 19, 2019 9:40 pm
Forum: QCAD 'How Do I' Questions
Topic: How to add objects cloned objects to a Document (scripting)?
Replies: 1
Views: 205

Re: How to add objects cloned objects to a Document (scripting)?

Nevermind, can `forceNew` with:

Code: Select all

expAddOp.addObject(debris[i], true, true);
by garciadelcastillo
Fri Jul 19, 2019 9:03 pm
Forum: QCAD 'How Do I' Questions
Topic: How to add objects cloned objects to a Document (scripting)?
Replies: 1
Views: 205

How to add objects cloned objects to a Document (scripting)?

Hi there! Question: using the ECMA scripting interface, how can I add cloned Objects to a document, without overriding the original ones? Description: I am writing a script that recursively explodes all RBlockReferenceEntities in a document, i.e. retrieves all the REntities inside a block, and adds ...
by garciadelcastillo
Fri Jul 19, 2019 3:14 pm
Forum: QCAD 'How Do I' Questions
Topic: Check QCAD version from CLI
Replies: 0
Views: 233

Check QCAD version from CLI

Hi there! Is there a way to check the QCAD version from the CLI? Something like: $ qcad -v Or... $ qcad -no-gui -allow-multiple-instances -autostart -v I am trying to add a check on my batch routines to see if the local qcad distro is updated to the correct version, or prompt the user to update if n...
by garciadelcastillo
Thu Jul 18, 2019 7:56 pm
Forum: QCAD Troubleshooting and Problems
Topic: Layers with `$` symbol in their name do not rasterize with dwg2bmp
Replies: 2
Views: 350

Re: Layers with `$` symbol in their name do not rasterize with dwg2bmp

Feature request: it would be nice if QCAD spit some kind of warning message when trying to render a layer with a name that doesn't exist (and perhaps render nothing), rather than silently rendering an empty image. :D
by garciadelcastillo
Thu Jul 18, 2019 7:39 pm
Forum: QCAD Troubleshooting and Problems
Topic: Layers with `$` symbol in their name do not rasterize with dwg2bmp
Replies: 2
Views: 350

Re: Layers with `$` symbol in their name do not rasterize with dwg2bmp

Oooooh, ok, `$` have to escaped...! This works: qcad.exe -no-gui -allow-multiple-instances -autostart scripts\Pro\Tools\Dwg2Bmp\Dwg2Bmp.js -background=white -width=1024 -height=1024 -force -antialiasing -monochrome -color-correction -zoom-all -no-weight-margin -layer="Layer_with_\$" -outfile="Layer_...
by garciadelcastillo
Thu Jul 18, 2019 7:33 pm
Forum: QCAD Troubleshooting and Problems
Topic: Layers with `$` symbol in their name do not rasterize with dwg2bmp
Replies: 2
Views: 350

Layers with `$` symbol in their name do not rasterize with dwg2bmp

Hi! I am having problems rasterizing layers with `$` symbols in their names: they always show up empty. Given the following file: layernames.dwg A full raster yields no problem: layernames.dwg.png Running rasterization on a layer without `$` in its name works fine: qcad.exe -no-gui -allow-multiple-i...
by garciadelcastillo
Wed Jul 17, 2019 10:53 pm
Forum: QCAD Troubleshooting and Problems
Topic: Blocks not rendering on layer with dwg2bmp
Replies: 3
Views: 202

Re: Blocks not rendering on layer with dwg2bmp

Wow, thank you for the quick response andrew, specially given your timezone. This solution would work for the corner case when content is on layer "0", but we need a more general solution. I have tried exploding the blocks, but I often get entities displaced to 0,0 and messes up the zoom level on re...
by garciadelcastillo
Wed Jul 17, 2019 9:01 pm
Forum: QCAD Troubleshooting and Problems
Topic: Blocks not rendering on layer with dwg2bmp
Replies: 3
Views: 202

Blocks not rendering on layer with dwg2bmp

Hi there! I have the following file, with all the layers active: 2PLUMBING_ground.dwg If I render the whole thing (removing hatches and minimizing line weights), it looks like this: 2PLUMBING_ground.dwg.png But now, if I only render the "FURN" layer, I get this: 2PLUMBING_ground.dwg_LAYER_FURN.png W...
by garciadelcastillo
Fri Jun 14, 2019 8:45 am
Forum: QCAD Troubleshooting and Problems
Topic: Strange line weight on line type
Replies: 5
Views: 661

Re: Strange line weight on line type

Sounds good.

In your code, are 0 the vertex index and 7 the line width in drawing units? Should I then iterate over all vertices in the polyline, setting Start and EndWidth? How about using RPolyline.setWidth(double) to set the width of the whole thing?

Thanks a lot!
by garciadelcastillo
Tue Jun 11, 2019 9:41 pm
Forum: QCAD Troubleshooting and Problems
Topic: Strange line weight on line type
Replies: 5
Views: 661

Re: Strange line weight on line type

Ooooh, I see, that makes sense. So, how could I change that through ECMAScript? I only see getters for the vertices on the RPolylineEntity class: https://www.qcad.org/doc/qcad/latest/developer/class_r_polyline_entity.html#aa4b4ce04c4bb59bd7a607a473dbad57c https://www.qcad.org/doc/qcad/latest/develop...
by garciadelcastillo
Tue Jun 11, 2019 7:10 pm
Forum: QCAD Troubleshooting and Problems
Topic: Strange line weight on line type
Replies: 5
Views: 661

Strange line weight on line type

Hi there! Problem: when I "dwg2bmp" a file with special line types, they render very thick! Description: running into a strange issue with line weights for non-continuous line types. If I try to rasterize the following file: 01-07a55.dwg I get this: 01-07a55.dwg.png But as far as I can tell inspecti...
by garciadelcastillo
Mon Jun 10, 2019 6:46 pm
Forum: QCAD 'How Do I' Questions
Topic: Create DWG from PDF?
Replies: 1
Views: 254

Create DWG from PDF?

Hi there,

Is there any way to convert a PDF file with vector information into a DWG/DXF file? I looking specifically at batch automating this process with a script, CLI-style ;)

Thanks!
by garciadelcastillo
Mon Jun 10, 2019 6:04 pm
Forum: QCAD Troubleshooting and Problems
Topic: Strange things happening with blocks in file
Replies: 4
Views: 457

Re: Strange things happening with blocks in file

Hi Andrew,

Is there any way to detect which blocks use block transforms from the ECMAScript API? While the FR goes through, I would like at least to be able to remove those blocks from the drawing prior to rasterizing them.

Thanks!
by garciadelcastillo
Thu Jun 06, 2019 7:31 pm
Forum: QCAD Troubleshooting and Problems
Topic: Strange things happening with blocks in file
Replies: 4
Views: 457

Strange things happening with blocks in file

Hi there, Problem: I am running into a strange problem with some block references in a reduced number of cad files being rendered in strange places. Description: I have a routine that batch-rasterizes cad files. The script relies on "dwg2bmp" with the "-zoom-all" argument. However, I started noticin...

Go to advanced search