Search found 11 matches

by ckomurlu
Tue Jun 30, 2009 11:52 am
Forum: QCAD 2.1/2.2 Installation and Upgrades
Topic: Qcad 2.2.1 pro qcadscripting module build problem
Replies: 5
Views: 18062

Hi, I have downloaded QSA from trolltech. By the way, I really can't figure out why it's excluded from the whole package. I have built it and obtained a lib file copied in lib/ directory of all other Qt libs inside Qt home directory. I retried to built qcadscripting module. It was OK, I obtained lib...
by ckomurlu
Mon Jun 29, 2009 12:04 pm
Forum: QCAD 2.1/2.2 Installation and Upgrades
Topic: Qcad 2.2.1 pro qcadscripting module build problem
Replies: 5
Views: 18062

Qcad 2.2.1 pro qcadscripting module build problem

Hi, I'm trying to build QCAD 2.2.1's qcadscripting module. I do qmake with no problem. Then at make command, I get the error report given below: In file included from src/qsa/qs_scripter.cpp:25: src/qsa/qs_scripter.h:29:27: error: qsinterpreter.h: No such file or directory src/qsa/qs_scripter.h:30:2...
by ckomurlu
Fri Jun 05, 2009 1:05 pm
Forum: QCAD 2.1/2.2 Installation and Upgrades
Topic: Qcad 2.2.1 pro link problem: libQtGui.a
Replies: 1
Views: 12970

Hello, In this problem, qcad cannot reach X11 lib at linking. Hence in Makefile, adding -lX11 option to the lib list is enough to solve X11 related problems. Then, a second undefined reference problem occurs. The error report is: In function `QTimerInfoList::getTime(timeval&)': qeventdispatcher_unix...
by ckomurlu
Thu Jun 04, 2009 4:58 pm
Forum: QCAD 2.1/2.2 Installation and Upgrades
Topic: Qcad 2.2.1 pro link problem: libQtGui.a
Replies: 1
Views: 12970

Qcad 2.2.1 pro link problem: libQtGui.a

Hi, I try to build Qcad 2.2.1 pro on Ubuntu 9.04 with Qt4.4.3 built statically. All modules of Qcad were built except qcad. The compilation of qcad module went alright but I got stuck at linking with the error below: /home/bilko/workbench/qt-all-opensource-src-4.4.3//lib/libQtGui.a(qapplication_x 11...
by ckomurlu
Wed Jun 03, 2009 12:56 pm
Forum: QCAD 2.1/2.2 Installation and Upgrades
Topic: Qcad 2.2.1 pro compilation problem: qjpcodecs qjpeg qgif
Replies: 11
Views: 27260

Hi, Related to the previous post, I just added three parameters to configure command which andrew suggested. The configure command I run: ./configure -static -qt-libpng -qt-libjpeg -qt-gif -qt-libtiff -qt-zlib -release -no-xfixes -no-stl -fast -no-xinerama -no-exceptions -no-separate-debug-info -no-...
by ckomurlu
Wed Jun 03, 2009 8:32 am
Forum: QCAD 2.1/2.2 Installation and Upgrades
Topic: Qcad 2.2.1 pro compilation problem: qjpcodecs qjpeg qgif
Replies: 11
Views: 27260

Hi, I'm trying to compile Qt since then using the command of the previous post, I'm stuck at an error occurring at `make´. The error message is: undefined reference to `qt_plugin_instance_qsqlite()' Indeed, the original message is much longer, unfortunately, I've lost it. I know this problem may be ...
by ckomurlu
Tue May 19, 2009 9:57 am
Forum: QCAD 2.1/2.2 Installation and Upgrades
Topic: Qcad 2.2.1 pro compilation problem: qjpcodecs qjpeg qgif
Replies: 11
Views: 27260

Hello, This time, I tried to compile QCAD 2.2.1 in a fresh Ubuntu 9.04. Instead of Ubuntu repositories Qt4 libraries, I have downloaded Qt 4.4.3 from Trolltech, compiled it and then tried to compile QCAD. Qt seems to be compiled correctly, I cheked the lib and include paths. They are just as told in...
by ckomurlu
Fri May 08, 2009 7:29 pm
Forum: QCAD 2.1/2.2 Installation and Upgrades
Topic: Qcad 2.2.1 pro compilation problem: qjpcodecs qjpeg qgif
Replies: 11
Views: 27260

I tried to downgrade Qt4 using Synaptic which is told, able to do it in Package menu. Unfortunately, this option is disabled for Qt4. However, for libqt4-core, the package explanation is given as: This is a dummy transitional package to enable installation of other Debian packages linked against Qt ...
by ckomurlu
Fri May 08, 2009 6:00 pm
Forum: QCAD 2.1/2.2 Installation and Upgrades
Topic: Qcad 2.2.1 pro compilation problem: qjpcodecs qjpeg qgif
Replies: 11
Views: 27260

You're right, $QTDIR and $QMAKESPEC were not set. I set them and retried to build. I get the final error of the first post at this topic. It means that, I no longer need to set codecs path explicitly in the makefile. What I wonder now is, how other qcad libraries were built without those environment...
by ckomurlu
Fri May 08, 2009 5:22 pm
Forum: QCAD 2.1/2.2 Installation and Upgrades
Topic: Qcad 2.2.1 pro compilation problem: qjpcodecs qjpeg qgif
Replies: 11
Views: 27260

I've checked qt4 files in system directories. Lib files I found, e.g. those which are in /usr/share/lib, are so files. So as far as I know this means that they are dynamically linking libraries.

Regards
by ckomurlu
Thu May 07, 2009 1:48 pm
Forum: QCAD 2.1/2.2 Installation and Upgrades
Topic: Qcad 2.2.1 pro compilation problem: qjpcodecs qjpeg qgif
Replies: 11
Views: 27260

Qcad 2.2.1 pro compilation problem: qjpcodecs qjpeg qgif

Hello, I'm trying to compile Qcad 2.2.1.0-1 on Ubuntu 9.04 with Qt4.5 which is installed via Synaptic. I used build_qcad.sh script located in scripts directory. At the stage of "--- building qcad ---"I got this error report: rm: cannot remove `qcad': No such file or directory Project MESSAGE: Proper...

Go to advanced search