Page 1 of 1

SVG2DWG

Posted: Wed Jun 22, 2016 10:54 pm
by bens
Hi, I'm new to QCAD but liking what I've seen so far and the following question is the deal breaker for me:

I'm trying to use the terminal to convert an svg to a dwg with the following command:

/Applications/QCAD.app/Contents/Resources/svg2dwg -t DWG R27 Downloads/eas22.svg

but I'm getting these errors:

Warning: RScriptHandlerEcma::eval: script engine exception: "Error: :-1:-1: Wrong number/types of arguments for RDocumentInterface.exportFile().\n<native>(undefined, 'DWG') at -1\nmain() at :scripts/Pro/Tools/Svg2Dwg/Svg2Dwg.js:70\n<global>() at :scripts/Pro/Tools/Svg2Dwg/Svg2Dwg.js:78"
Warning: "main() at :scripts/Pro/Tools/Svg2Dwg/Svg2Dwg.js:70\n<global>() at :scripts/Pro/Tools/Svg2Dwg/Svg2Dwg.js:78"
Warning: At least one uncaught exception:
Warning: "main() at :scripts/Pro/Tools/Svg2Dwg/Svg2Dwg.js:70\n<global>() at :scripts/Pro/Tools/Svg2Dwg/Svg2Dwg.js:78"
22:49:50: Debug: "<global>() at 70"

I'm running QCAD version 3.15.3 on a MAC Elcapitan.

I've tried various combinations but end up with pretty much exactly the same errors

I've trawled the internet but cannot find any documentation on the svg2dwg command

Any steer in the right direction would be much appreciated

Cheers

Ben

Re: SVG2DWG

Posted: Thu Jun 23, 2016 7:21 am
by andrew
bens wrote:/Applications/QCAD.app/Contents/Resources/svg2dwg -t DWG R27 Downloads/eas22.svg
The name of the output file has to be specified for this tool. Also DWG R27 has to be put in quotes since it's one argument but contains a space:

/Applications/QCAD.app/Contents/Resources/svg2dwg -t "DWG R27" -o output.dwg Downloads/eas22.svg

Re: SVG2DWG

Posted: Mon Jul 04, 2016 11:43 pm
by bens
Hi Andrew...sorry for my tardy reply, I was expecting a notification via email!

Worked an absolute charm so thank you very much for your speedy response.

I shall be purchasing this software

Many thanks again

Ben