[solved] Missing icons

Discussion forum for contributors and developers who are using the QCAD ECMAScript development platform or the C++ plugin interface or who are otherwise looking to contribute to QCAD (translations, documentation, etc).

Moderator: andrew

teegee
Active Member
Posts: 26
Joined: Wed Sep 21, 2016 5:51 am

[solved] Missing icons

Postby teegee » Sat Mar 11, 2017 5:32 am

When I compile from git on linux, with 'make release' or QT creator, several icons are missing. Mostly in the options toolbar, so far. For example, if I do AR, the direction icons are missing; there's just a shaded square and an invisible square.

Any idea what could cause this? I think this happened after I had to rearrange my qcad project directory layout (the new submodule detection stuff didn't like my setup).

User avatar
andrew
Site Admin
Posts: 5318
Joined: Fri Mar 30, 2007 6:07 am

Re: Missing icons

Postby andrew » Mon Mar 13, 2017 8:32 am

Do you get any warnings about files not being found in stderr?

Warning: Cannot open file 'scripts/.../.../...svg', because: No such file or directory

teegee
Active Member
Posts: 26
Joined: Wed Sep 21, 2016 5:51 am

Re: Missing icons

Postby teegee » Mon Mar 13, 2017 11:24 am

andrew wrote:Do you get any warnings about files not being found in stderr?

Warning: Cannot open file 'scripts/.../.../...svg', because: No such file or directory


No, nothing appears on the console at all when I activate AR, or press the blank/shaded square.

User avatar
andrew
Site Admin
Posts: 5318
Joined: Fri Mar 30, 2007 6:07 am

Re: Missing icons

Postby andrew » Mon Mar 13, 2017 12:20 pm

OK. I cannot explain this unfortunately. If you want to look deeper into it, the contents of the options toolbar is loaded from UI files (e.g. scripts/Draw/Arc/ArcCPA/ArcCPA.ui). The icons are in the same directory scripts/Draw/Arc/ArcCPA.

teegee
Active Member
Posts: 26
Joined: Wed Sep 21, 2016 5:51 am

Re: Missing icons

Postby teegee » Mon Mar 13, 2017 1:02 pm

Well, I just did a 'git clean -fdx' to wipe everything and recompiled from scratch. The icons are back now.. Sorry to bother you with it :)


Return to “QCAD Developers and Contributors”

Who is online

Users browsing this forum: No registered users and 3 guests