Meta grid on top of drawing

Use this forum to ask questions about how to do things in QCAD.

Moderator: andrew

Forum rules
Always indicate Operating system, QCAD version
Attach Drawing files, Screenshots
Post one question per topic.
Post Reply
OmeJan
Newbie Member
Posts: 3
Joined: Sat Jan 21, 2017 4:10 pm

Meta grid on top of drawing

Post by OmeJan » Sat Jan 21, 2017 4:21 pm

When drawing elements on the meta grid lines, the element seems to disappear under the meta grid. Is there a setting to put the grid under the drawing instead of on top of the drawing?

User avatar
Husky
Moderator/Drawing Help/Testing
Posts: 2190
Joined: Wed May 11, 2011 9:25 am
Location: USA

Re: Meta grid on top of drawing

Post by Husky » Sat Jan 21, 2017 6:29 pm

Hello OmeJan - welcome to the forum.
OmeJan wrote:When drawing elements on the meta grid lines, the element seems to disappear under the meta grid. Is there a setting to put the grid under the drawing instead of on top of the drawing?
To have a better contrast between elements and Grid you can adjust the color for the Grid below Application Preferences:
Husky-2017.01.21-03.png
Husky-2017.01.21-03.png (37.53 KiB) Viewed 1684 times
Husky-2017.01.21-02.png
Husky-2017.01.21-02.png (2.15 KiB) Viewed 1684 times
Work smart, not hard: QCad Pro

OmeJan
Newbie Member
Posts: 3
Joined: Sat Jan 21, 2017 4:10 pm

Re: Meta grid on top of drawing

Post by OmeJan » Sat Jan 21, 2017 6:59 pm

Thank you Husky, that just helped a little. That is when screen-based line types switched on and with the view zoomed in quite strongly. When zooming out the lines are hidden again. When drawing in Draft mode the meta grid keeps hiding lines, no matter the zooming rate.
Apparently there is no setting to get the grid lines behind the drawing.

User avatar
Husky
Moderator/Drawing Help/Testing
Posts: 2190
Joined: Wed May 11, 2011 9:25 am
Location: USA

Re: Meta grid on top of drawing

Post by Husky » Sat Jan 21, 2017 7:34 pm

OmeJan wrote:Apparently there is no setting to get the grid lines behind the drawing.
No, there is no setting for something like that but it sounds to me that your setting for the Grid is on "Auto". Auto means that QCAD will change the visibility of a Grid regarding to the Zoom Factor. To avoid that in my drawings my settings are:
Husky-2017.01.21-04.png
Husky-2017.01.21-04.png (63.67 KiB) Viewed 1680 times
Husky-2017.01.21-05.png
Husky-2017.01.21-05.png (35.12 KiB) Viewed 1680 times
Work smart, not hard: QCad Pro

OmeJan
Newbie Member
Posts: 3
Joined: Sat Jan 21, 2017 4:10 pm

Re: Meta grid on top of drawing

Post by OmeJan » Sat Jan 21, 2017 8:01 pm

My settings were not on Auto and looked similar to yours. Guess I just got to deal with it. Thanks again :-)

User avatar
Husky
Moderator/Drawing Help/Testing
Posts: 2190
Joined: Wed May 11, 2011 9:25 am
Location: USA

Re: Meta grid on top of drawing

Post by Husky » Sat Jan 21, 2017 8:28 pm

You are welcome!
Work smart, not hard: QCad Pro

User avatar
andrew
Site Admin
Posts: 5710
Joined: Fri Mar 30, 2007 6:07 am

Re: Meta grid on top of drawing

Post by andrew » Mon Jan 23, 2017 8:59 am

OmeJan wrote:Is there a setting to put the grid under the drawing instead of on top of the drawing?
No. The reason is that the meta grid would become invisible if there are horizontal or vertical lines at metagrid positions or very thick lines or solid fills.

The trick to make sure that neither the meta grid nor your entities are ever hidden by each other is to use a transparent color for the meta grid. To do that, choose the color "Others.." in the color preferences and make sure to set the alpha or opacity or transparency value of the color for example to 50%.

jvalencia
Active Member
Posts: 48
Joined: Mon Jun 29, 2015 8:26 pm

Re: Meta grid on top of drawing

Post by jvalencia » Fri Jan 05, 2018 11:31 am

Hello, I must say that this is stopping me from using the grid altogether. Since I work in draft mode almost exclusively, it's a bit of a nightmare for me.

It seems the grid "layer" is over the objects.

An example of a good working grid (IMHO) is the Blender one. I'd love to have its behaviour in QCad.
2018-01-05-102558_2560x1080_scrot.png
Blender: unselected object
2018-01-05-102558_2560x1080_scrot.png (2.75 KiB) Viewed 1403 times
2018-01-05-102554_2560x1080_scrot.png
Blender: selected object
2018-01-05-102554_2560x1080_scrot.png (2.91 KiB) Viewed 1403 times
2018-01-05-102008_2560x1080_scrot.png
Qcad: draft mode, lines totally hidden
2018-01-05-102008_2560x1080_scrot.png (3.19 KiB) Viewed 1403 times
2018-01-05-102000_2560x1080_scrot.png
Qcad: with line width, grid over the lines
2018-01-05-102000_2560x1080_scrot.png (3.26 KiB) Viewed 1403 times

User avatar
andrew
Site Admin
Posts: 5710
Joined: Fri Mar 30, 2007 6:07 am

Re: Meta grid on top of drawing

Post by andrew » Fri Jan 05, 2018 11:43 am

Again, if you make the grid color transparent (default), it will never hide anything completely.

Here's a drawing in draft mode with meta grid on:
Screen Shot 2018-01-05 at 10.42.41.png
Screen Shot 2018-01-05 at 10.42.41.png (35.24 KiB) Viewed 1402 times
Grid color:
Screen Shot 2018-01-05 at 10.43.59.png
Screen Shot 2018-01-05 at 10.43.59.png (44.72 KiB) Viewed 1401 times
Meta grid color:
Screen Shot 2018-01-05 at 10.44.05.png
Screen Shot 2018-01-05 at 10.44.05.png (45.15 KiB) Viewed 1401 times

jvalencia
Active Member
Posts: 48
Joined: Mon Jun 29, 2015 8:26 pm

Re: Meta grid on top of drawing

Post by jvalencia » Fri Jan 05, 2018 12:44 pm

Hello Andrew, I tried that. It's working a bit better but still far from what I desired.

While I can see the lines now, they are still blended with the grid lines, losing some color:
2018-01-05-114009_2560x1080_scrot.png
2018-01-05-114009_2560x1080_scrot.png (3.38 KiB) Viewed 1398 times
When I move my mouse over the green circle, it's highlighted and brought over the grid. Still losing some brightness though:
Attachments
2018-01-05-114026_2560x1080_scrot.png
2018-01-05-114026_2560x1080_scrot.png (1.86 KiB) Viewed 1398 times

User avatar
andrew
Site Admin
Posts: 5710
Joined: Fri Mar 30, 2007 6:07 am

Re: Meta grid on top of drawing

Post by andrew » Fri Jan 05, 2018 12:54 pm

You might want to increase the contrast between background color and grid color and make the grid more transparent. I think the gray background with gray grid color is causing the issue.

jvalencia
Active Member
Posts: 48
Joined: Mon Jun 29, 2015 8:26 pm

Re: Meta grid on top of drawing

Post by jvalencia » Fri Jan 05, 2018 3:02 pm

That worked! Moved to a Dark Cyan at 50 Alpha Channel value.

May it be an issue with the option that prevents dark/clear colors against the background or the color lightness threshold?
2018-01-05-135623_2560x1080_scrot.png
2018-01-05-135623_2560x1080_scrot.png (2.79 KiB) Viewed 1394 times

Post Reply

Return to “QCAD 'How Do I' Questions”