Setting dimention units

Use this forum to ask questions about how to do things in QCAD.

Moderator: andrew

Forum rules
Always indicate Operating system, QCAD version
Attach Drawing files, Screenshots
Post one question per topic.
Post Reply
Junior Member
Posts: 20
Joined: Sun Sep 30, 2018 4:44 pm

Setting dimention units

Post by mlwoy » Wed May 15, 2019 6:49 am

Operating system Windows 7
Qcad version

Built a drawing a month ago and have been modifying it for a while. Tonight I tried to dimension the drawing and the units showed up as metric. The units are set on inches however every time i draw a dimension line it shows up in millimeters. The old dimension lines show up in inches but any added now come in in metric. This is happening not only in one drawing but others as well.

When I use "Info" and "Distance to Point" the measurement comes up in inches.

How do I reset the program to dimension in inches.

I downloaded a dfx file the night before and tried to dimension it and it was in millimeters, I tried to convert the drawing to inches and could not change it what ever I did. So some way I must have messed up the setting.

Please help

User avatar
Moderator/Drawing Help/Testing
Posts: 2571
Joined: Wed May 11, 2011 9:25 am
Location: USA

Re: Setting dimention units

Post by Husky » Wed May 15, 2019 8:04 am

I'm not sure what you have done with that drawing but here a basic info:

If you have a metric drawing (lets say mm) and you convert it with the "Convert Drawing Unit" tool below Menu / Edit to imperial (lets say inch) then QCAD will recalculate everything in your drawing to the chosen new unit.
Example: If a line was drawn with a lengths of 100 mm then it is now a line with 3.937... inch.

If you use the "Drawing Preferences" below Menu / Edit to change the drawing unit then QCAD will ONLY change the name of the unit.
Example: If a line was drawn with a lengths of 100 mm then it is now a line with 100 inch.

An other possibility would be that you used a scale factor for dimensioning and forgot to change that again. Please doublecheck the dim option bar for the scale factor. I assume it needs to be 1:1. That would explain why the Info tools shows everything in inches.
Work smart, not hard: QCad Pro

Post Reply

Return to “QCAD 'How Do I' Questions”