Wrong map tiles generation

If you are having problems with QCAD, post here. Please report bugs through our Bug Tracker instead.

Always attach your original DXF or DWG file and mentions your QCAD version and the platform you are on.

Moderator: andrew

Forum rules
Always indicate Operating system, QCAD version
Attach Drawing files, Screenshots
Post Reply
VannyKo
Newbie Member
Posts: 4
Joined: Mon Jul 19, 2021 8:26 am

Wrong map tiles generation

Post by VannyKo » Mon Jul 19, 2021 8:50 am

Hi there!
I'm trying to generate maptiles from DXF files and everething seems fine except one file.
Service info: Win 10 Professional, QCAD v 3.26.4.

Generating goes in 2 steps:
1 - converting dxf coordinate system from EPSG:31467 to EPSG:3857
2 - generating map tiles from converted DXF-file.

Convertion runs dwgmapconvert.bat file with more arguments
- [logFileName] -crs-in=EPSG:31467 -crs-out=EPSG:3857 -f -o[outputFileName] -[sourceFileName]

Generating runs dwg2maptiles.bat file with more arguments
-[fileName] -web-mercator -skip-empty -b transparent -f -o [outputDirName] -z 17-17 -[logFileName]

In good case I'm getting all needed tiles, but with one file I'm gettint just a small part of tiles. I suppose that problem is in source DXF-file, but I have no idea about what's wrong with it.

I attached this wrong file and also attached log-files for converting and generating tiles.

Can you give me a direction to look for source of this problem?
Attachments
60f51d423f710936a29a75b7.dxf
Bad DXF file
(879.55 KiB) Downloaded 7 times
dxf_to_mt_60f51d423f710936a29a75b7_z_17.dxf.log.log
Generating log file
(471 Bytes) Downloaded 6 times
dwgmapconvert_DXF_to_WGS84_292_60f51d423f710936a29a75b7.log
Converting log file
(285 Bytes) Downloaded 6 times

User avatar
andrew
Site Admin
Posts: 7814
Joined: Fri Mar 30, 2007 6:07 am

Re: Wrong map tiles generation

Post by andrew » Mon Jul 19, 2021 10:35 am

The maptile output with the file you have attached, using the two commands as indicated above:
https://qcad.org/res/tmpmap (only level 17)

This looks fine here as far as I can tell.

Do you run the tools in a command line prompt or from an application / script / web service / etc?

In the latter case, please rerun in a command line prompt to rule out any issues with running the processes from your application / script.

VannyKo
Newbie Member
Posts: 4
Joined: Mon Jul 19, 2021 8:26 am

Re: Wrong map tiles generation

Post by VannyKo » Mon Jul 19, 2021 11:20 am

Hi andrew. Thanks for answering.
My code executes batch file. I can not attach it to this post. This is the content of this file:

qcadcmd.com -allow-multiple-instances -autostart scripts\Pro\Tools\DwgMapConvert\DwgMapConvert.js -crs-in=EPSG:31467 -crs-out=EPSG:3857 -f -o "output.dxf" "60f51d423f710936a29a75b7.dxf"

qcadcmd.com -allow-multiple-instances -autostart scripts\Pro\Tools\Dwg2MapTiles\Dwg2MapTiles.js "d:\QCAD\output\outputLog.log" -web-mercator -skip-empty -z 18-18 -f -b transparent -o "d:\QCAD\output" "output.dxf"

User avatar
andrew
Site Admin
Posts: 7814
Joined: Fri Mar 30, 2007 6:07 am

Re: Wrong map tiles generation

Post by andrew » Mon Jul 19, 2021 11:31 am

Again, please do try to rerun these commands manually from a command line prompt (cmd.exe) to rule out any issues with running the processes from your application.

A common problem is that a child process is forced to terminate prematurely if the calling application does not wait for its child processes to terminate. Please note that these are issues unrelated to QCAD or the QCAD Command Line Tools but related to process management and programming.

VannyKo
Newbie Member
Posts: 4
Joined: Mon Jul 19, 2021 8:26 am

Re: Wrong map tiles generation

Post by VannyKo » Mon Jul 19, 2021 11:34 am

In a fact this is just sample .bat-file to reproduce my issue. I start it manually. Console output in my case looks like on the attached image.

As you can see only 2 tiles were generated fo 18 zoom level after execution. This is too small count for this DXF.
Attachments
2021-07-19_11-41-03.png
Console ouput
2021-07-19_11-41-03.png (37.83 KiB) Viewed 398 times

VannyKo
Newbie Member
Posts: 4
Joined: Mon Jul 19, 2021 8:26 am

Re: Wrong map tiles generation

Post by VannyKo » Tue Jul 20, 2021 7:45 am

Just new information. I've found that this DXF uses MText elements. All DXF without it have no problem with tiles generation. Can it be the reason?

User avatar
andrew
Site Admin
Posts: 7814
Joined: Fri Mar 30, 2007 6:07 am

Re: Wrong map tiles generation

Post by andrew » Tue Jul 20, 2021 9:03 pm

Thanks for the details. It's a problem with the spatial index that ships with Windows packages. We have released a snapshot release (3.26.4.5) today which comes with a different spatial index module that should fix the problem. The update is available from your download link under "Snapshots".

Post Reply

Return to “QCAD Troubleshooting and Problems”