Ruler not showing

If you are having problems with QCAD, post here. Please report bugs through our Bug Tracker instead.

Always attach your original DXF or DWG file and mentions your QCAD version and the platform you are on.

Moderator: andrew

Forum rules

Always indicate your operating system and QCAD version.

Attach drawing files and screenshots.

Post one question per topic.

Post Reply
phidrho
Newbie Member
Posts: 6
Joined: Wed Oct 13, 2021 10:52 am
Location: Croatia

Ruler not showing

Post by phidrho » Wed Oct 13, 2021 6:59 pm

Kubuntu 18.04

QCAD Professional
Version:
3.26.4.0 (3.26.4)
Internet:
QCAD.org
Build Date:
Jun 4 2021
Revision:
0bb4334
Qt Version:
5.8.0
Architecture:
x86_64
Compiler:
gcc 4.8.1

I have disabled scrollbars and left show rulers enabled, but after restarting QCAD no rulers or numbers are shown, only small triangle thicks.
I tried this also today on Windows 10 with the same version of QCAD (last) and got the same effect.

I have also disabled grid automatic scaling because I need to know what grid exactly represents - similar to paper with grid (in my case it's set up to 0.01 m for the main grid (1x1 cm), and 0.1 for meta grid (1x1 dm)), otherwise, I don't need to see the grid.
Attachments
Screenshot_20211013_195402.png
rulers missing
Screenshot_20211013_195402.png (234.11 KiB) Viewed 105 times
Screenshot_20211013_195118.png
settings
Screenshot_20211013_195118.png (110.04 KiB) Viewed 105 times

User avatar
andrew
Site Admin
Posts: 7970
Joined: Fri Mar 30, 2007 6:07 am

Re: Ruler not showing

Post by andrew » Wed Oct 13, 2021 9:01 pm

The ruler and the grid are directly linked. If no grid can be shown (because it would be too dense) no rulers are shown either.

My recommendation would be to enable auto grid scaling and look at the right bottom corner of the graphics view to check the current grid spacing.

phidrho
Newbie Member
Posts: 6
Joined: Wed Oct 13, 2021 10:52 am
Location: Croatia

Re: Ruler not showing

Post by phidrho » Wed Oct 13, 2021 9:36 pm

Hi andrew,

first of all, thank you for the fast reply.
1) how to enable this current grid spacing display
2) when I'm zoomed in and the grid is displayed, even then there is no ruler displayed, please see the video demonstration on YouTube:
QCAD ruler missing even when the grid is shown

It seems that the ruler is working properly before restarting after disabling auto grid - when there is no grid then there is no ruler, but when zoomed in and the grid is shown the ruler is also shown. But unfortunately after the software is restarted then it starts to misbehave - no ruler display at all.

User avatar
andrew
Site Admin
Posts: 7970
Joined: Fri Mar 30, 2007 6:07 am

Re: Ruler not showing

Post by andrew » Wed Oct 13, 2021 10:23 pm

phidrho wrote:
Wed Oct 13, 2021 9:36 pm
1) how to enable this current grid spacing display
I'm afraid, this is only shown when scrollbars are shown as it's in the corner space between the scrollbars.

I'd recommend to use the default settings as follows:
- Enable auto scale grid
- Show scrollbars (for the grid display)

Post Reply

Return to “QCAD Troubleshooting and Problems”