Page 1 of 1

QCAD3 opens with "plastique" and I want clearlook [SOLVED]

Posted: Sun Jul 22, 2012 5:42 pm
by ggsalas
Hi, qcad3 test opens well, but now that i buy qcad3 profesional open with a ugly theme of qt4, and i want the default theme, i think is clearlooks.

Thanks.

Re: Qcad3 profesional open with "plastique" and I want clear

Posted: Sun Jul 22, 2012 8:32 pm
by andrew
You can try different styles with the -style option:

./qcad -style cleanlooks

Note that some styles crash on 64bit Linux systems. If you are using a 64bit Linux, the start-up script file 'qcad' forces the style to 'plastique'. To try a different style on a 64bit Linux system, start the QCAD binary directly:

Code: Select all

cd ~/opt/qcad-3.0.0-prof-linux
LD_LIBRARY_PATH=. ./qcad-bin -style cleanlooks
To try other styles, replace 'cleanlooks' with: cde, plastique, gtk, motif, windows, windowsvista, windowsxp

Re: Qcad3 profesional open with "plastique" and I want clear

Posted: Wed Jul 25, 2012 1:09 pm
by ggsalas
Thanks Andrew, but how I can set plastique to default?

I'm using a 32bit Ubuntu OS

Re: Qcad3 profesional open with "plastique" and I want clear

Posted: Wed Jul 25, 2012 1:14 pm
by andrew
You could either:

- change the start-up script 'qcad' (last line):
LD_LIBRARY_PATH="$DIR" "$binary" -style plastique $OPT1 $OPT2 "[email protected]"
or
- create an alias for qcad -> qcad -style plastique
or
- create your own wrapper script

Re: Qcad3 profesional open with "plastique" and I want clear

Posted: Wed Jul 25, 2012 7:45 pm
by ggsalas
Hi Andrew,

With your code didn't work, but it works adding gtk in the option 2. See capture 1: don't work, and capture 2: OK.

Thanks

Re: Qcad3 profesional open with "plastique" and I want clear

Posted: Wed Jul 25, 2012 8:21 pm
by andrew
Good - glad you've solved it.