Bug: Different angular dimension in viewport and model

If you are having problems with QCAD, post here. Please report bugs through our Bug Tracker instead.

Always attach your original DXF or DWG file and mentions your QCAD version and the platform you are on.

Moderator: andrew

Forum rules
Always indicate Operating system, QCAD version
Attach Drawing files, Screenshots
Post Reply
johan162
Junior Member
Posts: 12
Joined: Sun Jul 08, 2018 10:16 pm

Bug: Different angular dimension in viewport and model

Post by johan162 » Mon Jul 30, 2018 9:53 am

I have a model where one of the details is as following:
Screen Shot 2018-07-30 at 10.30.32.png
Screen Shot 2018-07-30 at 10.30.32.png (43.4 KiB) Viewed 568 times
However, when I create a viewport and display the part in the the layout the angular measurement is screwed up (sorry no better technical term ...)
Screen Shot 2018-07-30 at 10.31.06.png
Screen Shot 2018-07-30 at 10.31.06.png (45.8 KiB) Viewed 568 times
Having done some experiments with some different angles it always seems like the layout angle is always +31 degrees more (up to rounding).

In the model it should be noted that the part displayed is a detail copied with a different scale as to Zoom in on a detail in order to put dimensions on it. It was created by copying a part of the model and pasting it back in the model but with 3x zoom.

I have also included the full .dxf file in the hope that it helps you both reproduce and fix this issue
Attachments
buggy_angular_in_viewport.dxf
(203.48 KiB) Downloaded 20 times

User avatar
Husky
Moderator/Drawing Help/Testing
Posts: 2145
Joined: Wed May 11, 2011 9:25 am
Location: USA

Re: Bug: Different angular dimension in viewport and model

Post by Husky » Mon Jul 30, 2018 4:31 pm

I'm able to reproduce the issue.
johan162 wrote:
Mon Jul 30, 2018 9:53 am
Having done some experiments with some different angles it always seems like the layout angle is always +31 degrees more (up to rounding).
I don't see that pattern - in my test the changes are floating regarding to the new position in Paper_Space.

Best change to get that fixed would be to file a Bugreport. Please use http://www.ribbonsoft.com/bugtracker
Work smart, not hard: QCad Pro

johan162
Junior Member
Posts: 12
Joined: Sun Jul 08, 2018 10:16 pm

Re: Bug: Different angular dimension in viewport and model

Post by johan162 » Mon Jul 30, 2018 4:56 pm

Filed as: "FS#1792 - Different angular dimension in viewport and model"

You are also right about the +31 degrees I hypothesized. It seems to change randomly when you remove and re-add the angular dimension.

An interesting bug ...

Post Reply

Return to “QCAD Troubleshooting and Problems”