[solved] Qcad not running on ubuntu 20

Post your question about installing or upgrading QCAD.

Moderator: andrew

Post Reply
vinlin
Newbie Member
Posts: 4
Joined: Thu Apr 22, 2021 2:46 pm

[solved] Qcad not running on ubuntu 20

Post by vinlin » Thu Apr 22, 2021 2:55 pm

Hello,

Qcad is not running. Permissions is not the problem.
Where should I start looking for solving this problem?
I tried installing these 2 types:
qcad-3.26.2-trial-linux-x86_64.run
qcad-3.26.2-pro-linux-x86_64.tar.gz

My system:
Ubuntu 20.04.2 LTS 64-bit
gnome 3.36.8
X11
Intel Core i5-5200U [email protected] x 4

[email protected]:~/opt$ tar xfvz qcad-3.25.2-pro-linux-x86_64.tar.gz
tar (child): qcad-3.25.2-pro-linux-x86_64.tar.gz: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now
[email protected]:~/opt$ export QT_DEBUG_PLUGINS=1
[email protected]:~/opt$ ./qcad
bash: ./qcad: No such file or directory
[email protected]:~/opt$
Last edited by vinlin on Thu Apr 22, 2021 4:03 pm, edited 1 time in total.

User avatar
andrew
Site Admin
Posts: 7636
Joined: Fri Mar 30, 2007 6:07 am

Re: Qcad not running on ubuntu20

Post by andrew » Thu Apr 22, 2021 3:59 pm

Please run QCAD form a terminal and post the output:

Code: Select all

cd ~/opt/qcad-3.26.2-pro-linux-x86_64
./qcad

vinlin
Newbie Member
Posts: 4
Joined: Thu Apr 22, 2021 2:46 pm

Re: Qcad not running on ubuntu 20

Post by vinlin » Thu Apr 22, 2021 4:05 pm

Hi Andrew,

This is the output:

[email protected]:~/opt$ cd ~/opt/qcad-3.26.2-pro-linux-x86_64
bash: cd: /home/flaptoptoo/opt/qcad-3.26.2-pro-linux-x86_64: No such file or directory
[email protected]:~/opt$ ./qcad
bash: ./qcad: No such file or directory
[email protected]:~/opt$

From the download folder I copied the tar file to the /home/opt folder, that didn't work. (rightclickmenu)
From the other computer opt folder is doesn't work either.
Hope you can help!

User avatar
andrew
Site Admin
Posts: 7636
Joined: Fri Mar 30, 2007 6:07 am

Re: Qcad not running on ubuntu 20

Post by andrew » Thu Apr 22, 2021 4:11 pm

QCAD is not yet installed on your computer. Please download the file labelled "QCAD Professional 3.26.2 for Linux 64bit (Installer)". This will give you the file "qcad-3.26.2-pro-linux-x86_64.run". This file has to be run (executed) to install QCAD.

Please refer to our detailed installation guide for Linux at:
https://www.qcad.org/en/component/conte ... tion-linux

vinlin
Newbie Member
Posts: 4
Joined: Thu Apr 22, 2021 2:46 pm

Re: Qcad not running on ubuntu 20

Post by vinlin » Thu Apr 29, 2021 12:07 pm

Hi Andrew,

I managed to get the proper file installed.
However qcad is still not running.
If I put in LD_LIBRARY_PATH=. ldd qcad-bin this is what I get:

[email protected]:~/opt/qcad-3.26.2-pro-linux-x86_64$ LD_LIBRARY_PATH=. ldd qcad-bin
linux-vdso.so.1 (0x00007ffd0e5be000)
libqcadecmaapi.so => /home/flaptoptoo/opt/qcad-3.26.2-pro-linux-x86_64/./libqcadecmaapi.so (0x00007f21595dc000)
libqcadentity.so => /home/flaptoptoo/opt/qcad-3.26.2-pro-linux-x86_64/./libqcadentity.so (0x00007f2159299000)
libqcadcore.so => /home/flaptoptoo/opt/qcad-3.26.2-pro-linux-x86_64/./libqcadcore.so (0x00007f2158adc000)
libQt5Core.so.5 => /home/flaptoptoo/opt/qcad-3.26.2-pro-linux-x86_64/./libQt5Core.so.5 (0x00007f21583bc000)
libstdc++.so.6 => /lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f21581cb000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f21581ae000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f2157fbc000)
libqcadgrid.so => /home/flaptoptoo/opt/qcad-3.26.2-pro-linux-x86_64/./libqcadgrid.so (0x00007f2157db1000)
libqcadgui.so => /home/flaptoptoo/opt/qcad-3.26.2-pro-linux-x86_64/./libqcadgui.so (0x00007f2157b10000)
libqcadoperations.so => /home/flaptoptoo/opt/qcad-3.26.2-pro-linux-x86_64/./libqcadoperations.so (0x00007f21578e8000)
libqcadsnap.so => /home/flaptoptoo/opt/qcad-3.26.2-pro-linux-x86_64/./libqcadsnap.so (0x00007f21576d3000)
libqcadspatialindex.so => /home/flaptoptoo/opt/qcad-3.26.2-pro-linux-x86_64/./libqcadspatialindex.so (0x00007f21574c3000)
libqcadstemmer.so => /home/flaptoptoo/opt/qcad-3.26.2-pro-linux-x86_64/./libqcadstemmer.so (0x00007f2157294000)
libQt5PrintSupport.so.5 => /home/flaptoptoo/opt/qcad-3.26.2-pro-linux-x86_64/./libQt5PrintSupport.so.5 (0x00007f2157026000)
libQt5Widgets.so.5 => /home/flaptoptoo/opt/qcad-3.26.2-pro-linux-x86_64/./libQt5Widgets.so.5 (0x00007f21567f5000)
libQt5Gui.so.5 => /home/flaptoptoo/opt/qcad-3.26.2-pro-linux-x86_64/./libQt5Gui.so.5 (0x00007f215605a000)
libQt5Script.so.5 => /home/flaptoptoo/opt/qcad-3.26.2-pro-linux-x86_64/./libQt5Script.so.5 (0x00007f2155bd2000)
libQt5ScriptTools.so.5 => /home/flaptoptoo/opt/qcad-3.26.2-pro-linux-x86_64/./libQt5ScriptTools.so.5 (0x00007f2155902000)
libQt5Network.so.5 => /home/flaptoptoo/opt/qcad-3.26.2-pro-linux-x86_64/./libQt5Network.so.5 (0x00007f215557c000)
libQt5Xml.so.5 => /home/flaptoptoo/opt/qcad-3.26.2-pro-linux-x86_64/./libQt5Xml.so.5 (0x00007f2155342000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f21551f3000)
libQt5Svg.so.5 => /home/flaptoptoo/opt/qcad-3.26.2-pro-linux-x86_64/./libQt5Svg.so.5 (0x00007f2154fa0000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f2154f7b000)
libicui18n.so.56 => ./libicui18n.so.56 (0x00007f2154ae2000)
libicuuc.so.56 => ./libicuuc.so.56 (0x00007f215472a000)
libicudata.so.56 => ./libicudata.so.56 (0x00007f2152d47000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f2152d41000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f2152d34000)
libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f2152d18000)
libgthread-2.0.so.0 => /lib/x86_64-linux-gnu/libgthread-2.0.so.0 (0x00007f2152d13000)
libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007f2152bea000)
/lib64/ld-linux-x86-64.so.2 (0x00007f215ab34000)
libspatialindexnavel.so => /home/flaptoptoo/opt/qcad-3.26.2-pro-linux-x86_64/./libspatialindexnavel.so (0x00007f2152972000)
libGL.so.1 => /lib/x86_64-linux-gnu/libGL.so.1 (0x00007f21528e8000)
libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f2152875000)
libGLdispatch.so.0 => /lib/x86_64-linux-gnu/libGLdispatch.so.0 (0x00007f21527bd000)
libGLX.so.0 => /lib/x86_64-linux-gnu/libGLX.so.0 (0x00007f2152789000)
libX11.so.6 => /lib/x86_64-linux-gnu/libX11.so.6 (0x00007f215264a000)
libxcb.so.1 => /lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f2152620000)
libXau.so.6 => /lib/x86_64-linux-gnu/libXau.so.6 (0x00007f215261a000)
libXdmcp.so.6 => /lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f2152612000)
libbsd.so.0 => /lib/x86_64-linux-gnu/libbsd.so.0 (0x00007f21525f8000)
[email protected]:~/opt/qcad-3.26.2-pro-linux-x86_64$


How do i proceed?

User avatar
andrew
Site Admin
Posts: 7636
Joined: Fri Mar 30, 2007 6:07 am

Re: Qcad not running on ubuntu 20

Post by andrew » Thu Apr 29, 2021 12:10 pm

Again, please run QCAD form a terminal and post the output:

Code: Select all

cd ~/opt/qcad-3.26.2-pro-linux-x86_64
./qcad

vinlin
Newbie Member
Posts: 4
Joined: Thu Apr 22, 2021 2:46 pm

Re: Qcad not running on ubuntu 20

Post by vinlin » Thu Apr 29, 2021 2:28 pm

Hi Andrew,

[email protected]:~/opt/qcad-3.26.2-pro-linux-x86_64$ ./qcad
QCAD version 3.26.2
15:27:03: Debug: Renaming old unversioned config file from '/home/flaptoptoo/.config/QCAD/QCAD3.conf' to '/home/flaptoptoo/.config/QCAD/QCAD3_old.conf'

qcad is starting!

Thank you.

Post Reply

Return to “QCAD Installation and Upgrades”