Converted Fonts

Use this forum to ask questions about how to do things in QCAD 2.1/2.2.

Moderator: andrew

Registered Member
Posts: 2
Joined: Sun Apr 24, 2011 2:22 pm

Converted Fonts

Post by rgenzer » Sun Apr 24, 2011 2:39 pm

I have successfully compiled and installed ttf2cxf. I had to do the work do the around with the include and the printf statement (thank you Niels Ole Salscheider). The program now generates what looks like a valid cxf file. I install that file in the proper directory and QCAD recognizes the newly installed font (it comes up in the list of fonts). This seems like great news but.... QCAD doesn't really use the actual font. Instead, it is like this new font is a default font (e.g. just stick lines, etc.). The truetype font that I converted (Edwardian script from Windows) is a very script-like font which is nothing like what QCAD displays.

I opened the converted cxf file and the format looks like all the other cxf files... there are separations using [] for all the different letters and after that there are a ton of numerical commands. I found 2 differences... there is a # that proceeds the ASCII (I removed that) and there is no actual character after the [] (I added that). Still no luck.

I also tried copying of the existing font files into a new one and messed around with the numerical commands. Nothing seems to work.

Another observation... these new fonts are NOT listed in alphabetical order in the list of fonts. Instead, they are listed at the top of the list. After my 2 "new" fonts, the rest are listed in alphabetical order. Is that some clue that something is wrong?

It seems to me that there has to be some special command to make QCAD actually recognize the newly compiled font.

Please help.

UPDATE: To provide a test... I took one of the existing font files and copied it to a new name. I then went back into QCAD and saw the entry with that new name and used it. SAME RESULT (e.g. the font drew in "standard" instead of the actual font). So, I must conclude that for some reason, QCAD is not allowing me to add a new font file, regardless of the font file contents. I tried this on the Community addition (came with my Ubuntu build) as well as the professional (demo version installed on Windows 7 as a test).


Return to “QCAD 2.1/2.2 'How Do I' Questions”