Setting the grid for imperial drawings

Tips and tricks you want to share with other users. Tutorials, user submitted documentation, etc.

Moderator: andrew

Locked
User avatar
andrew
Site Admin
Posts: 5641
Joined: Fri Mar 30, 2007 6:07 am

Setting the grid for imperial drawings

Post by andrew » Wed Nov 29, 2017 4:36 pm

Configuring the Drawing Unit

First, make sure that your drawing is actually configured to the desired unit, so QCAD can detect your drawing unit.
Edit > Drawing Preferences > General > Drawing Unit:
Screen Shot 2017-11-29 at 15.25.33.png
Screen Shot 2017-11-29 at 15.25.33.png (91.54 KiB) Viewed 3187 times
Configuring the Dimension Format

Imperial drawings often use a grid that is configured to a fraction of an inch (e.g. 1/8", 1/6", etc). If the grid gets too dense for QCAD to display, it will scale it up either by a factor of 10 (for decimal number formats) or by a factor of 2 (for fractional number formats). To make sure QCAD scales the grid up by a factor of 2, configure the dimension format to either Fractional or Architectural:
Edit > Drawing Preferences > Dimension > Dimension Settings:
Screen Shot 2017-11-29 at 15.25.43.png
Screen Shot 2017-11-29 at 15.25.43.png (131.5 KiB) Viewed 3187 times
Configuring the Grid

You can set up the desired grid spacing under
Edit > Drawing Preferences > General > Grid
Screen Shot 2017-11-29 at 15.25.53.png
Screen Shot 2017-11-29 at 15.25.53.png (122.72 KiB) Viewed 3187 times
Grid Autoscaling

If you do not want QCAD to automatically scale the grid depending on the zoom level, you can disable this setting under
Edit > Application Preferences > Graphics View > Grid:
Screen Shot 2017-11-29 at 15.26.07.png
Screen Shot 2017-11-29 at 15.26.07.png (120.96 KiB) Viewed 3187 times
QCAD will then either display the grid at the configured setting or not at all if the grid would get too dense.

Locked

Return to “QCAD Tips and Tutorials”