Page 1 of 1

Bug while drawing and snapping; snapping won't remain on

Posted: Sat Aug 02, 2008 12:50 am
by ttrw
Andrew, there's a bug in the snap tool, where after drawing a line and then repeating the action with the tool still 'open', snapping stops working. I haven't tried the other snapping tools, but it is the orthographical restrict tools that I am noticing the bug.

using latest QCad build.


Posted: Sat Aug 02, 2008 9:09 am
by ttrw
I should point out that the Autosnap feature seems to dominate, and in order to return to the original choice, I have to deselect the restrict tool, then re-select again. It dramatically slows down workflow.

Posted: Tue Aug 26, 2008 4:41 pm
by toyryla
I can report the same problem with QCad (Professional) on Xubuntu 8.04 platform.

Posted: Tue Sep 02, 2008 9:44 am
by DJohnston
The persistent auto snap does slow things down alot. I hope this will be configurable soon or removed. I run Qcad on both Windows and Linux.

Posted: Tue Sep 23, 2008 8:37 pm
by DJohnston
It would be really great if this persistent auto snap could be disabled. For the work I do, I use the grid very often and as the mode always defaults back to auto, it does slow down workflow very much. I would like the snap setting to stay as it is set and only change when I need it to change. I had hoped this last update would have removed this feature.
PS - look forward to reading the Qcad book, which I have ordered.