[solved] Mouse cursor disappears

Use this forum for all posts and questions about the free QCAD Community Edition version 3

Moderator: andrew

Post Reply
fconnoll
Registered Member
Posts: 2
Joined: Sun Sep 19, 2021 6:29 pm

[solved] Mouse cursor disappears

Post by fconnoll » Sun Sep 19, 2021 6:46 pm

Hi,
I just started using QCAD Community Edition 3.26.4.0 on mac os 10.15.7.
I made a few simple drawings (some lines and rectangles), I was able to manipulate positions and sizes using the toolbars. The drawings have only 1 layer AFAIK (a default new drawing with only a few objects drawn on it). I was able to Edit/Copy and then Edit/Paste a selected object (or group of objects, or grouped objects) from one drawing to another (e.g., a group of rectangles).
Then something seems to have broken with the mouse cursor.
After Edit/Copy when I select Edit/Paste, sometimes mouse selection cross hairs show up briefly (or maybe show up until the mouse in over the drawing area) or does not show up at all, then I am not able to place the pasted object with the mouse (or maybe the object shows up eventually after some clicking, but not where the mouse cursor was).
It seems sometimes paste does not work at all, sometimes it seems I can paste the object using the command line. This all may be just erroneous input, but the basic problem seems the mouse cursor disappears and the mouse cannot be used to place the object.
Also, when creating new objects the mouse cursor also is not working in the same manner (cannot place a new object with the mouse, but seems can using the command line).
The behavior repeats across closing and reopening QCAD.
I tried un-installing and re-installing it (drop into Trash and then reinstall from dmg, but if there are some settings files left over somewhere I did not know about or remove those).
Thanks.
fconnoll

User avatar
Husky
Moderator/Drawing Help/Testing
Posts: 3834
Joined: Wed May 11, 2011 9:25 am
Location: USA

Re: Mouse cursor disappears

Post by Husky » Sun Sep 19, 2021 7:04 pm

fconnoll wrote:
Sun Sep 19, 2021 6:46 pm
I tried un-installing and re-installing it (drop into Trash and then reinstall from dmg, but if there are some settings files left over somewhere I did not know about or remove those).
QCAD is using a separate ini file for all settings. Uninstalling the program will not do it - you have to delete that ini file to reset QCAD.

How?
https://qcad.org/en/tutorial-resetting- ... figuration

Note: The program QCAD needs to be closed for this procedure.
Work smart, not hard: QCad Pro

If a thread is considered as "solved" please change the title of the first post to "[solved] Title...". Thanks!

fconnoll
Registered Member
Posts: 2
Joined: Sun Sep 19, 2021 6:29 pm

Re: Mouse cursor disappears

Post by fconnoll » Sun Sep 26, 2021 2:50 pm

Thank you. That worked.

Post Reply

Return to “QCAD Community Edition”