QCAD v3.15 on Ubuntu 16.04 LTS - Build problem

Use this forum for all posts and questions about the free QCAD Community Edition version 3

Moderator: andrew

Post Reply
xelis
Newbie Member
Posts: 3
Joined: Thu Jul 14, 2016 8:24 pm

QCAD v3.15 on Ubuntu 16.04 LTS - Build problem

Post by xelis » Mon Jul 18, 2016 2:27 pm

Hi,
I followed the instructions from here and after qmake -r command I received following message:

Code: Select all

Reading .../qcad/src/src.pro
 Reading .../qcad/src/3rdparty/3rdparty.pro
Project ERROR: Script bindings not available for Qt version . You can add them to src/3rdparty/qt-labs-qtscriptgenerator- or use another version of Qt.
qmake -v command provides this result:

Code: Select all

QMake version 2.01a
Using Qt version 4.8.4 in /usr/local/Trolltech/Qt-4.8.4/lib
Do you know some hints ?

Sorry if I posted in the wrong place, it was hard to choose between Professional or Community place.

User avatar
andrew
Site Admin
Posts: 6183
Joined: Fri Mar 30, 2007 6:07 am

Re: QCAD v3.15 on Ubuntu 16.04 LTS - Build problem

Post by andrew » Mon Jul 18, 2016 6:56 pm

The error happens in qcad/src/3rdparty/3rdparty.pro. It looks like the variable QT_VERSION is empty on your system for some reason. In any case, you should be able to work around the problem by passing QT_VERSION to qmake explicitely:

Code: Select all

qmake QT_VERSION=4.8.4

xelis
Newbie Member
Posts: 3
Joined: Thu Jul 14, 2016 8:24 pm

Re: QCAD v3.15 on Ubuntu 16.04 LTS - Build problem

Post by xelis » Sat Jul 23, 2016 11:04 pm

Step 4 from Compiling QCAD from Sources on Linux was completed after I added the command sudo make install in Step 3 (after the make command).

Now, in Step 5, I have a new error:

Code: Select all

make[4]: Entering directory '/home/radu/qcad/src/3rdparty/spatialindexnavel'
rm -f libspatialindexnavel.so
g++ -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.6/lib -shared -o libspatialindexnavel.so release/BulkLoader.o release/Index.o release/Leaf.o release/Node.o release/RTree.o release/Statistics.o release/LineSegment.o release/MovingPoint.o release/MovingRegion.o release/Point.o release/Region.o release/SpatialIndexImpl.o release/TimePoint.o release/TimeRegion.o release/Buffer.o release/DiskStorageManager.o release/MemoryStorageManager.o release/RandomEvictionsBuffer.o release/rand48.o release/Tools.o   -L/usr/local/Trolltech/Qt-4.8.6/lib -L/usr/X11R6/lib -L/home/radu/qcad/release -lQtWebKit -L/usr/local/Trolltech/Qt-4.8.6/lib -lQtScriptTools -lQtScript -L/usr/X11R6/lib -lQtSvg -lQtXmlPatterns -lQtOpenGL -lQtUiTools -L/home/radu/qt-everywhere-opensource-src-4.8.6/lib -lQtXml -lGL -lQtDesigner -lQtHelp -lQtSql -lQtGui -lQtNetwork -lQtCore -lpthread  
/usr/bin/ld: cannot find -lQtWebKit
/usr/bin/ld: cannot find -lQtXmlPatterns
collect2: error: ld returned 1 exit status
Makefile.Release:148: recipe for target '../../../release/libspatialindexnavel.so' failed
Do you know what is this error?
Thank you.

User avatar
andrew
Site Admin
Posts: 6183
Joined: Fri Mar 30, 2007 6:07 am

Re: QCAD v3.15 on Ubuntu 16.04 LTS - Build problem

Post by andrew » Wed Jul 27, 2016 10:09 am

Your Qt version appears to be have been compiled without WebKit or other optional modules. If you have compiled your copy of Qt (recommended), you can check for possible reasons by looking at the output of ./configure (in the Qt directory).

If you have followed our instructions for compiling Qt, this should not be the case, since we force webkit to be compiled (-webkit). Configure should stop if any required libraries or headers cannot be found.

xelis
Newbie Member
Posts: 3
Joined: Thu Jul 14, 2016 8:24 pm

Re: QCAD v3.15 on Ubuntu 16.04 LTS - Build problem

Post by xelis » Tue Aug 23, 2016 7:05 pm

Hi,
I strictly followed your instructions and make release command finished with following message:

Code: Select all

make release -> ../../generated_cpp/com_trolltech_qt_webkit/qtscript_QGraphicsWebView.cpp:8:30: fatal error: qgraphicswebview.h: No such file or directory
compilation terminated.
Makefile.Release:259: recipe for target 'release/qtscript_QGraphicsWebView.o' failed
Is there someone that successfully build QCad under Ubuntu 16.04 ? I'm asking just to know if something is missing/erroneous in my system.

Post Reply

Return to “QCAD Community Edition”