Qcad GUI fonts

Post your question about installing or upgrading QCAD.

Moderator: andrew

Post Reply
aseila
Registered Member
Posts: 2
Joined: Wed Dec 13, 2017 9:32 pm

Qcad GUI fonts

Post by aseila » Wed Dec 13, 2017 9:40 pm

I am running Qcad Professional 13.8.1.0 on a Dell XPS laptop running Ubuntu Gnome 17.04. This laptop has a very high resolution screen running at 3480 x 2160 dpi. As a result, the fonts and icons are very small. Is there a way to scale the fonts and icons so I can keep the high resolution but have elements of the GUI large enough that I don't need magnifying glasses? Thanks.
Andy Seila

User avatar
Husky
Moderator/Drawing Help/Testing
Posts: 2488
Joined: Wed May 11, 2011 9:25 am
Location: USA

Re: Qcad GUI fonts

Post by Husky » Wed Dec 13, 2017 10:39 pm

Hi Andy - welcome to the QCAD forum.
aseila wrote:Is there a way to scale the fonts and icons so I can keep the high resolution but have elements of the GUI large enough that I don't need magnifying glasses?
Have you tried your luck with adjusting the settings below Application Preferences / Widgets like Toolbars?

Husky-2017.12.13-01.png
Husky-2017.12.13-01.png (33.07 KiB) Viewed 2332 times
And there is more to find below Widgets ... :wink:
Work smart, not hard: QCad Pro

User avatar
andrew
Site Admin
Posts: 6158
Joined: Fri Mar 30, 2007 6:07 am

Re: Qcad GUI fonts

Post by andrew » Thu Dec 14, 2017 10:31 am

You might also want to experiment with some Qt environment variables as specified at:
http://doc.qt.io/qt-5/highdpi.html#high ... port-in-qt

Code: Select all

QT_SCALE_FACTOR=1.2
or even

Code: Select all

QT_DEVICE_PIXEL_RATIO=2
One way to apply such environment variables only for QCAD is as follows:

Code: Select all

cd ~/opt/qcad-3.19.2-pro-linux-x86_64
QT_SCALE_FACTOR=1.2 ./qcad
or:

Code: Select all

cd ~/opt/qcad-3.19.2-pro-linux-x86_64
QT_DEVICE_PIXEL_RATIO=2 ./qcad

aseila
Registered Member
Posts: 2
Joined: Wed Dec 13, 2017 9:32 pm

Re: Qcad GUI fonts

Post by aseila » Fri Dec 15, 2017 7:00 pm

Thank you for your help. Changing the icon size in Application Preferences -> Toolbars did help with small icons, but nothing else including setting some Qt environment variables would change font sizes in the menus. In the end, I think this is an OS and video problem, not a Qcad problem because there are some other problems with icon and font sizes in other areas such as the boot screen. There are some settings in the Gnome Tweak Tool to set scaling factors and font sizes, but they do not affect Qcad's font sizes in the GUI. Maybe the best solution for me right now is to reduce my resolution a little and wait for a solution from Ubuntu.
Thanks again.
Andy

Post Reply

Return to “QCAD Installation and Upgrades”