Copy lines to a new layer

Use this forum to ask questions about how to do things in QCAD.

Moderator: andrew

Forum rules
Always indicate Operating system, QCAD version
Attach Drawing files, Screenshots
Post one question per topic.
Post Reply
frostipops
Registered Member
Posts: 2
Joined: Tue Apr 02, 2019 10:23 am

Copy lines to a new layer

Post by frostipops » Tue Apr 02, 2019 10:29 am

Hi
Total amateur here, using the free version...
I'm trying to copy lines (essentially a floor plan) from one layer to another, but I want the lines to be in exactly the same location (i.e. so I can line up walls etc between a top floor and ground floor). There's probably a better / neater way of doing what I want but essentially I just need to duplicate the floor plan into a new layer so I can work on that...I can sort the select and copy but when I paste either (a) the lines disappear from the original layer or (b) the new lines float 'freehand' and do not duplicate on the original. I've tried duplicate also, but that just does it in the layer I'm working in...

Thanks

User avatar
Husky
Moderator/Drawing Help/Testing
Posts: 2591
Joined: Wed May 11, 2011 9:25 am
Location: USA

Re: Copy lines to a new layer

Post by Husky » Tue Apr 02, 2019 5:06 pm

Hi,

select what needs to be copied,
launch the clipboard tool "Copy with reference"
use the Command line, type in 0;0 to determine that the copy Reference Point is on absolute 0,
Click the target layer in the Layer List to make it active,
launch the clipboard tool "Paste",
make sure that in the up-poping Option Bar "To current Layer" is ticked,

Husky-2019.04.02-01.png
Husky-2019.04.02-01.png (7.27 KiB) Viewed 262 times

type in the Command Line 0;0 to tell the tool where to place the copy,
confirm with return, terminate the paste tool, done :wink:
Work smart, not hard: QCad Pro

frostipops
Registered Member
Posts: 2
Joined: Tue Apr 02, 2019 10:23 am

Re: Copy lines to a new layer

Post by frostipops » Wed Apr 03, 2019 10:55 am

Thanks!

Post Reply

Return to “QCAD 'How Do I' Questions”