QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

Tasklist

FS#1677 - Dimension: Scale option grayed out in model space

Attached to Project: QCAD
Opened by Husky (Husky) - Friday, 08 December 2017, 19:06 GMT+2
Last edited by Andrew (andrew) - Wednesday, 03 January 2018, 15:42 GMT+2
Task Type Bug Report
Category QCAD (main)
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Low
Priority Normal
Reported Version 3.19.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

... impossible to chose a scale in the DIM option bar.

This task depends upon

Closed by  Andrew (andrew)
Wednesday, 03 January 2018, 15:42 GMT+2
Reason for closing:  Fixed
Additional comments about closing:  https://github.com/qcad/qcad/commit/4ff5 be5d25a3050387b7cf0d61b0b75d8b77f81a
Comment by Andrew (andrew) - Friday, 08 December 2017, 19:19 GMT+2

Can you please attach your drawing? I cannot reproduce this here. Thanks.

Comment by Husky (Husky) - Friday, 08 December 2017, 20:26 GMT+2

Sure ;-)

it works in 3.18.1 and doesn't in 3.19.1

Comment by Husky (Husky) - Friday, 08 December 2017, 20:28 GMT+2

here they are

Comment by Andrew (andrew) - Friday, 08 December 2017, 21:01 GMT+2

Thanks. So I open this file ("dim scale broken 3.19.1.dxf") and draw for example a horizontal dimension with a scale factor in the options toolbar of "1:2" from 0,0 to 50,0. The dimension label shows "100" which seems to be correct. Can you please indicate where this goes wrong for you? Thanks.

Comment by Husky (Husky) - Friday, 08 December 2017, 21:08 GMT+2

My Scale option is grayed out / not active. I'm not able to adjust anything in that field. Not sure that my screenshot will show that clear enough ...

Comment by Husky (Husky) - Friday, 08 December 2017, 21:31 GMT+2

Additional info:
If I use a scale for dim in 3.18.1 (let say 1:2) / close QCAD / open 3.19.1 then I see for a second the remembered scale (1:2) in the option bar which then will be overwritten immediately with 1 and is then grayed out.
Happens on Win10

Comment by Andrew (andrew) - Friday, 08 December 2017, 22:33 GMT+2

I think I know what happened.
Can you try this workaround:
- Switch to paper space
- Create a dimension and while doing so, uncheck the "Auto" check box in the options toolbar
- Switch back to model space
- The scale combo should now be enabled again

Comment by Husky (Husky) - Friday, 08 December 2017, 23:42 GMT+2

Yes that works! Thanks for the fast solution!

Comment by Husky (Husky) - Monday, 01 January 2018, 20:41 GMT+2

Hi Andrew - may I ask you how this fix meant to work? I have still the same issue in 3.19.2.
Paper_Space DIM AUTO marked,
Model_Space DIM scale grayed out ...

Loading...